ASUS Eee Pad Transformer — TUTORIAL- Como reverter o Asus Transformer tf101/101G para a rom original ICS 4.0.3

  • Respostas:11
  • AbertoStickySem resposta
Conta desativada
  • Posts no fórum: 12.402

1/out/2013 17:27:19 via Web



O Asus Transformer , depois que colocamos uma rom personalizada, não reconhece mais o pacote de atualização/instalação das roms de fábrica , então ,vamos ver umas das várias formas que existem para voltar o seu tablet ao estado original.

Para o processo vamos precisar do ADB+drives, que você pode baixar aqui:adb_asus_tf101.rar

Vamos precisar também baixar a rom original do seu modelo(tf101 ou tf101g), para isso acessem a página de suporte Asus aqui:
support.asus.com



INSTALAÇÃO DA ROM ORIGINAL

1- Após baixar o pacote adb_asus_tf101.rar, descompacte ele em algum lugar no seu pc,vá na pasta adb driver e instale o driver referente ao seu sistema (x86/x64) clicando no aplicativo dpinst.

2- Após baixar o pacote da rom original, descompacte ela duas vezes, até aparecer uma pasta META-INF e um arquivo blob.

3- Recorte esse arquivo blob e cole na pasta do adb.

4- No seu tablet ative a depuração usb, geralmente está em configurações>desenvolvimento.
5- Conecte o seu tablet no pc e certifique-se que ele esteja com a bateria totalmente carregada.
6- Agora, no arquivo zip da rom descompacte ele uma vez, e o arquivo zip que surgir renomeie de WW_epad-user-9.x.x.x para EP101_SDUPDATE.zip , o mesmo nome vale para as duas versões, e copie para a raiz do seu cartão de memória ,mas mantenha ele fora do tablet por enquanto.
7- Desative seu antivirus e mate qualquer processo do Asus utility ou sync.
8- Vá na pasta do adb e segurando a tecla shift, clique com o botão direito do mouse, com isso irá abrir uma janela de dialogo, clique em abrir janela de comando aqui.

9- Se o comando deu certo irá abrir uma janela de comando como a da foto abaixo:

10- Na janela de comando digite os seguintes comandos:
adb devices - dê enter, esse comando é para o adb identificar o tablet,
-se o comando foi aceito corretamente , vai aparecer os seguintes dados na janela de comando:

11- Agora vamos colocar o arquivo blob dentro do sistema do seu tablet, para isso vamos digitar o seguintes comandos:
adb push blob /data/local - dê enter, esse processo deve demorar em torno de 10 minutos.
- se tudo deu certo vai aparecer os dados como os da foto abaixo:

12- Agora digite o seguinte comando:
adb shaell -dê enter, se o comando for aceito vai entrar no root do tablet como na foto abaixo

13- Agora digite o seguinte comando :
dd if=/data/local/blob of=/dev/block/mmcblk0p4 - dê enter.o processo deve demorar quase 10 minutos .
14- Após terminado o processo, desconecte o tablet e reinicie ele, vai aparecer uma barra de progresso na tela de inicio, isso indica que o arquivo blob está sendo flashado, isso irá retirar o recovery personalizado e deixará o tablet em bootloop.
15- Desligue o tablet, coloque o cartão de memória com o arquivo EP101_SDUPDATE.zip no tablet.
16- Pressione ao mesmo tempo os botões de volume para baixo+power até entrar a tela de acesso ao recovery.em seguida solte e pressione o botão volume para cima ,isso iniciará o processo de instalação da rom original, que deve demorar mais uns 10 minutos.Espere até o tablet reiniciar por conta.
NOTA:se aparecer o recovery personalizado, algo deu errado, você deve repetir o processo.


OBS.:Nem eu e nem o AndroidPit nos responsabilizamos por eventuais danos que possam ocorrer, faça por sua conta e risco.

— alterado em 1/out/2013 22:40:27

Quando você for seguir um tutorial,primeiro leia atentamente o passo a passo,em seguida leia os relatos das duvidas e dificuldades que outros tiveram ao fazer o tutorial, assim você terá toda a confiança para prosseguir com o tutorial sem problemas.
Se alguém lhe ajudou, não esqueça de agradecer, clicando no icone de positivo,isso incentiva quem está aqui disposto a ajudar .

  • Posts no fórum: 6

27/jun/2014 5:20:29 via Web

Olá Jefferson, estou com um problema no meu tablet, seguinte, instalei o CWR e quando fui atualizar a rom para um outra o mesmo ( cwm ) não monta o cartão de memoria nem a porta usb, consegui injetar o TWRP para dentro dele deu tudo certo, instalei a rom recovery para dentro dele e quando da boot fica parado na tela de inicialização, não sai disto, já tem uma semana que estou tentando e não consigo reverter o problema, efetuai o seu tutorial com adb mas, quando eu mando o comando ( dd if=/data/local/blob of=/dev/block/mmcblk0p4 ) ele me retorna assim, ( dd: can't open '/data/local/blob': Not a directorydd if=/data/local/blob of=/dev/block/mmcblk0p4 ), quer dizer que a pasta local não contém o arquivo blob, já estou perdendo as esperanças, peço a gentileza se souber de como contornar o problema me dar uma força, adiantando lhe agradeço muito.

Conta desativada
  • Posts no fórum: 12.402

27/jun/2014 5:26:37 via App

olá, tu já tentou refazer o primeiro comando?

Quando você for seguir um tutorial,primeiro leia atentamente o passo a passo,em seguida leia os relatos das duvidas e dificuldades que outros tiveram ao fazer o tutorial, assim você terá toda a confiança para prosseguir com o tutorial sem problemas.
Se alguém lhe ajudou, não esqueça de agradecer, clicando no icone de positivo,isso incentiva quem está aqui disposto a ajudar .

  • Posts no fórum: 6

27/jun/2014 5:35:33 via Web

Oi Jefferson, já foram efetuados todos os comandos até a linha que deu o erro, não consigo entrar com as teclas power + vol up, a tela fica preta mas no pc não tem acesso via adb, já testei inúmeros drivers e nenhum libera a porta devices, somente tenho acesso pelo modo TWRP modo apx, já instalei várias roms recovery todas ficam no boot com tela travada, muito obrigado pelo retorno, estou entrando em parafuso.

Conta desativada
  • Posts no fórum: 12.402

27/jun/2014 8:53:18 via App

bah e um problema, pelo apx também não vai?

Quando você for seguir um tutorial,primeiro leia atentamente o passo a passo,em seguida leia os relatos das duvidas e dificuldades que outros tiveram ao fazer o tutorial, assim você terá toda a confiança para prosseguir com o tutorial sem problemas.
Se alguém lhe ajudou, não esqueça de agradecer, clicando no icone de positivo,isso incentiva quem está aqui disposto a ajudar .

  • Posts no fórum: 6

27/jun/2014 15:47:30 via Web

Modo Apx está funcionando normal no bootloader, foi com ele que empurrei o TWRP para dentro via ADB e está funcionando normal, estou sem acesso ao /data. ele está lá mas sem acesso ao comandos.

Conta desativada
  • Posts no fórum: 12.402

27/jun/2014 16:15:35 via Web

que estranho, pelo que entendi então pelo twrp tu não consegue acessar o cartão? é isso?

Quando você for seguir um tutorial,primeiro leia atentamente o passo a passo,em seguida leia os relatos das duvidas e dificuldades que outros tiveram ao fazer o tutorial, assim você terá toda a confiança para prosseguir com o tutorial sem problemas.
Se alguém lhe ajudou, não esqueça de agradecer, clicando no icone de positivo,isso incentiva quem está aqui disposto a ajudar .

  • Posts no fórum: 6

27/jun/2014 17:22:17 via Web

Consigo sim acessar o cartão pelo twrp, o problema é que não consigo dar o comando ( dd if=/data/local/blob of=/dev/block/mmcblk0p4 )

Segue o que está acontecendo,

adb push blob /data/local
1331 KB/s (546820852 bytes in 400.950s)

adb shell
~ # dd if=/data/local/blob of=/dev/block/mmcblk0p4
dd: can't open '/data/local/blob': Not a directory

  • Posts no fórum: 6

27/jun/2014 17:28:00 via Web

Pelo que entendi do comando é que ele vai ler o blob e depois escrever na memoria com bloco 0p4, mas parece que não está tendo acesso, será que mandando o comando chmod para a pasta da certo?

— alterado em 27/jun/2014 17:42:35

  • Posts no fórum: 2

3/ago/2014 21:18:06 via Web

Olá!

Fiz todos os pass/comandos e correu tudo bem. No entanto, na altura de reiiniciar o tablet e colocar o cartão, não dá certo. Aparece o simbolo do Android com uma barra e de sseguida aparece o boneco do Android deitado e com um simbolo de perigo (vermelho e triangular). Parece-me que não está a conseguir ler o cartão ou algo do género.
Agora está em constante looping e nem desliga.
Pode ajudar-me? Obrigada.

  • Posts no fórum: 2

3/ago/2014 22:12:19 via Web

Olá novamente!

Já consegui, percebi que tinha copiado o ficheiro erradamente para o cartão. Agora tenho outro problema.... apareceu a barra azul, depois reiniciou sozinho, e agora não sai da parte em que o ecra tem o logotipo da asus e por baixo um circulo a girar... sei q pode demorar, mas está à tempo demais.

(...)

Passado algum tempo percebi o que estava a fazer mal... não sei se acontece sempre ou se é só no meu asus. Não sou muito entendida nisto mas tive que me desenrascar e ir fazendo por tentativas. Então para quem tiver este problema de não fazer meio de reiniciar, tentem o seguinte:
Voltem a reiniciar; depois de carregar no butao down+power não devemos carregar no butao up, devemos esperar que apareçam dois bonecos: à esquerda um que diz "wipe" e à direita um que é o boneco do Android; de seguida devemos seguir as indicações e escolher o da esquerda "wipe"( se não me engano é botao down para escolher e depois botao up para confirmar). Não sei o que era o simbolo do android mas, depois de pesquisar, percebi que wipe é formatar para a origem. O que aconteceu foi que formatou e instalou de seguida com o ficheiro que estava no microsd. Não sei o que era o outro simbolo, só sei que não fazia nada.

Para quem não percebe nada disto, como eu, aqui fica esta explicação. Devem fazer todos os passos que aqui está nesta pagina, é fundamental. No fim, se tiverem problemas, experimentem fazer o q eu fiz. Pode dar ou não.

Só uma nota (danger): existe um comando que está mal escrito não é sheall é shell, e o anterior tem um espaço depois de blob...

Depois de ter sofrido com isto tudo, até que parece ser um processo bem fácil :D

Obrigada por esta página! Está muito boa!!! :) :) :)

Sara

— alterado em 3/ago/2014 23:08:42