Motorola Moto G — [Tutorial] Instalação root, recovery, desbloqueamento do bootloader e retirada do aviso - XT1032/XT1033

  • Respostas:874
  • AbertoStickySem resposta
  • Posts no fórum: 19

25/abr/2014 5:04:29 via Web

Olair Junior

MatheusFerreira

Instalei o driver da Motorola (x64), instalei o Minimal, passei o SuperSU, liguei no modo bootloader, mas no prompt de comando não aparece o código. Fica só com < waiting for device >. O que faço?

Digite fastboot devices e veja se o seu pc reconhece o aparelho. Se não, instale o MotorolaDeviceManager_2.4.5 no seu computador e refaça o processo.

Deu certo com esse "MotorolaDevice...". Obrigado! Mas agora tenho outro problema/duvida: quando entro no "recovery" pra instalação do root, aparece a mensagem "Nenhum comando.". O que faço?

  • Posts no fórum: 1.239

25/abr/2014 11:05:18 via Web

Tentem dar "fastboot reboot-bootloader", flashar o recovery e ir direto a ele pelo menu do Bootloader mode. Aqui sempre funciona normal. Não estou entendendo esses erros.

▂ ▃ ▅ ▆ █
-- Nexus 5 / D821
-- AOSPA 4+
--- SoundCloud
--- YouTube

Leia o tutorial por inteiro duas vezes antes de executá-lo, atento a qualquer mínimo detalhe e aos arquivos baixados!

  • Posts no fórum: 331

25/abr/2014 13:49:31 via Web

Olair Junior

Lucas Silva

Olair Junior

Estamos a disposição. :)

Lucas Silva

Amigo, instalei o TWRP não deu certo, instalei o CWM tbm não... Aparece na tela: Nenhum comando. Não sei mais o que fazer!!!

Após mover a recovery que você fez o download (CWM ou TWRP) para a pasta adb, renomeie o arquivo baixado para recovery.img e abra o cmd neste diretório. No prompt digite:

fastboot flash recovery recovery.img

Eu fiz do jeito que vc disse, mas continua dizendo: nenhum comando. Esse TWRP que esta disponível para download nesse tutorial está funcionando mesmo?

  • Posts no fórum: 331

25/abr/2014 14:00:14 via Web

MatheusFerreira

Olair Junior

MatheusFerreira

Instalei o driver da Motorola (x64), instalei o Minimal, passei o SuperSU, liguei no modo bootloader, mas no prompt de comando não aparece o código. Fica só com < waiting for device >. O que faço?

Digite fastboot devices e veja se o seu pc reconhece o aparelho. Se não, instale o MotorolaDeviceManager_2.4.5 no seu computador e refaça o processo.

Deu certo com esse "MotorolaDevice...". Obrigado! Mas agora tenho outro problema/duvida: quando entro no "recovery" pra instalação do root, aparece a mensagem "Nenhum comando.". O que faço?

Lucas Silva

Tbm estou com esse mesmo problema!

  • Posts no fórum: 310

25/abr/2014 14:47:16 via Web

Tentem fazer o seguinte, baixem um dos dois recovery (eu prefiro o TWRP)

aí quando baixar(suponhamos q foi o twrp), muda o nome para: twrprecovery.img e jogue-o na pasta da sua rom stock

e da esses dois comandos (com ele já no recovery):

mfastboot.exe flash recovery twrprecovery.img
mfastboot reboot-bootloader

Daí só ir na opção recovery e ser feliz -

CHUPABrasil, leva goleada na educação, leva goleada na saúde e leva goleada no futebol.

60
Conta desativada
  • Posts no fórum: 12.402

25/abr/2014 15:09:11 via Web

olá pessoal, é o seguinte, pelomque eu andei analizando, em win 64 tem que executar o fastboot em modo de compatibilidade, a grnde maioria do pessoal que está com problemas é por que está com o win 64, no win 32 não tem quase problemas.

Quando você for seguir um tutorial,primeiro leia atentamente o passo a passo,em seguida leia os relatos das duvidas e dificuldades que outros tiveram ao fazer o tutorial, assim você terá toda a confiança para prosseguir com o tutorial sem problemas.
Se alguém lhe ajudou, não esqueça de agradecer, clicando no icone de positivo,isso incentiva quem está aqui disposto a ajudar .

  • Posts no fórum: 191

25/abr/2014 17:26:05 via Web

MatheusFerreira

Olair Junior

MatheusFerreira

Instalei o driver da Motorola (x64), instalei o Minimal, passei o SuperSU, liguei no modo bootloader, mas no prompt de comando não aparece o código. Fica só com < waiting for device >. O que faço?

Digite fastboot devices e veja se o seu pc reconhece o aparelho. Se não, instale o MotorolaDeviceManager_2.4.5 no seu computador e refaça o processo.

Deu certo com esse "MotorolaDevice...". Obrigado!
Mas agora tenho outro problema/duvida: quando entro no "recovery" pra instalação do root, aparece a mensagem "Nenhum comando.". O que faço?

Matheus e Lucas, que bom que vocês conseguiram desbloquear seus aparelhos. Já aconteceu isso comigo antes de instalar a recovery. Ou seja, isso acontece quando você tenta entrar na Recovery ela ainda não estando instalada. É bem provável que vocês não tenham instalado a Recovery corretamente. Como o Jefferson disse, talvez estejam tendo problemas devido ao sistema ser 64bits, mas vamos tentar refazer o processo de instalação da Recovery novamente seguindo os seguintes passos:

1- Baixe a Recovery ClockworkMod: http**://loki.rombitch.com/Devs/Dhacker29/MotoG/CWM-swipe-6.0.4.7-falcon.img

2- Conecte o Moto G ao computador via USB.

3- Renomeie a imagem da Recovery que você baixou para recovery

4- Mova a imagem da Recovery renomeada para o diretório “Minimal ADB and Fastboot”.

5- No PC, abra o cmd no diretório “Minimal ADB and Fastboot” e reinicie o aparelho no modo fastboot.

6- Estando o aparelho no modo fastboot, verifique se seu PC reconhece o aparelho digitando fastboot devices

• Se você não visualizar o número do seu serial, e ao invés dele visualizar "waiting for device", o fastboot não está configurado corretamente na sua máquina por falta de driver ou outro motivo qualquer.

• Se você visualizar "no permissions fastboot", tente executar o cmd como administrador.

7-. Flash o ClockworkMod Recovery no seu aparelho digitando o seguinte comando: fastboot flash recovery recovery.img

• Uma vez que o flash tenha sido completado com sucesso, reinicie o aparelho em fastboot e entre na recovery para verificar a instalação.

• Se após a reinicialização ainda assim, a Recovery não abrir, refaça o processo, mas desta vez não reinicie o aparelho após a instalação. Tente entrar na Recovery diretamente sem reinicia-lo.

Boa sorte. :)

— alterado em 1/mai/2014 4:22:40

  • Posts no fórum: 331

25/abr/2014 19:01:11 via Web

Olair Junior

MatheusFerreira

Olair Junior

MatheusFerreira

Instalei o driver da Motorola (x64), instalei o Minimal, passei o SuperSU, liguei no modo bootloader, mas no prompt de comando não aparece o código. Fica só com < waiting for device >. O que faço?

Digite fastboot devices e veja se o seu pc reconhece o aparelho. Se não, instale o MotorolaDeviceManager_2.4.5 no seu computador e refaça o processo.

Deu certo com esse "MotorolaDevice...". Obrigado! Mas agora tenho outro problema/duvida: quando entro no "recovery" pra instalação do root, aparece a mensagem "Nenhum comando.". O que faço?

Matheus e Lucas, que bom que vocês conseguiram desbloquear seus aparelhos. Já aconteceu isso comigo antes de instalar a recovery. Ou seja, isso acontece quando você tenta entrar na Recovery ela ainda não estando instalada. É bem provável que vocês não tenham instalado a Recovery corretamente. Como o Jefferson disse, talvez estejam tendo problemas devido ao sistema ser 64bits, mas vamos tentar refazer o processo de instalação da Recovery novamente seguindo os seguintes passos:

1- Baixe a Recovery ClockworkMod: http**://loki.rombitch.com/Devs/Dhacker29/MotoG/CWM-swipe-6.0.4.7-falcon.img

2- Conecte o Moto G ao computador via USB.

3- Renomeie a imagem da Recovery que você baixou para recovery.img

4- Mova a imagem da Recovery renomeada para o diretório “Minimal ADB and Fastboot”.

5- No PC, abra o cmd no diretório “Minimal ADB and Fastboot” e reinicie o aparelho no modo fastboot.

6- Estando o aparelho no modo fastboot, verifique se seu PC reconhece o aparelho digitando fastboot devices

• Se você não visualizar o número do seu serial, e ao invés dele visualizar "waiting for device", o fastboot não está configurado corretamente na sua máquina por falta de driver ou outro motivo qualquer.

• Se você visualizar "no permissions fastboot", tente executar o cmd como administrador.

7-. Flash o ClockworkMod Recovery no seu aparelho digitando o seguinte comando: fastboot flash recovery recovery.img

• Uma vez que o flash tenha sido completado com sucesso, reinicie o aparelho em fastboot e entre na recovery para verificar a instalação.

• Se após a reinicialização ainda assim, a Recovery não abrir, refaça o processo, mas desta vez não reinicie o aparelho após a instalação. Tente entrar na Recovery diretamente sem reinicia-lo.

Boa sorte. :)

Lucas Silva

Vou refazer o processo, depois volto com o resultado. Desde já obrigado pela atenção!!

  • Posts no fórum: 1.239

25/abr/2014 19:06:33 via Web

Olair, com adição da verificação da conexão (que acho desnecessária, uma vez que o próprio Bootloader mode adiciona um aviso quando conectado ao USB), o procedimento que você detalhou é a mesma coisa que tem no tutorial, e ainda priorizaste o CWM. Assim que eu reformular este tópico para o Markdown, adiciona rei um aviso para os usuários apenas prestarem atenção no nome do arquivo digitado, pode ser este o problema de muitos.

▂ ▃ ▅ ▆ █
-- Nexus 5 / D821
-- AOSPA 4+
--- SoundCloud
--- YouTube

Leia o tutorial por inteiro duas vezes antes de executá-lo, atento a qualquer mínimo detalhe e aos arquivos baixados!

  • Posts no fórum: 331

25/abr/2014 20:40:25 via Web

Cara, consegui!!! :) Só que nesse terceiro passo: "3- Renomeie a imagem da Recovery que você baixou para recovery.img", no lugar de renomear para "recovery.img", deve-se renomear assim: "recovery", só no cmd que precisa colocar a extensão ".img". Mas muito obrigado pela ajuda!! :D

  • Posts no fórum: 1.239

25/abr/2014 22:41:16 via Web

Independente do nome do recovery, o que conta é se você colocou o nome do arquivo certo junto com a extensão do mesmo.

▂ ▃ ▅ ▆ █
-- Nexus 5 / D821
-- AOSPA 4+
--- SoundCloud
--- YouTube

Leia o tutorial por inteiro duas vezes antes de executá-lo, atento a qualquer mínimo detalhe e aos arquivos baixados!

  • Posts no fórum: 191

26/abr/2014 3:58:08 via Web

Lucas Silva

Cara, consegui!!! :) Só que nesse terceiro passo: "3- Renomeie a imagem da Recovery que você baixou para recovery.img", no lugar de renomear para "recovery.img", deve-se renomear assim: "recovery", só no cmd que precisa colocar a extensão ".img". Mas muito obrigado pela ajuda!! :D

Fico feliz por você ter conseguido. E a observação da nomeação do arquivo foi um detalhe importante. Parabéns. Está progredindo. :)

  • Posts no fórum: 6

26/abr/2014 12:25:57 via Web

Fiz desbloqueio do bootloader no site da motorola,quando inserir o numero no aparelho ele reinicio,porem só ficava numa tela preta,porem tive que sai quando retornei ele estava descarregado,agora ele não carrega mais e não liga:O

  • Posts no fórum: 191

26/abr/2014 13:51:47 via Web

Rômulo Andrade

Fiz desbloqueio do bootloader no site da motorola,quando inserir o numero no aparelho ele reinicio,porem só ficava numa tela preta,porem tive que sai quando retornei ele estava descarregado,agora ele não carrega mais e não liga:O

Rômulo, que vacilo cara! Não faça mais esse tipo de procedimento com carga baixa da bateria, beleza!? Pois bem, conecte seu aparelho ao carregador e segure o botão power por dois minutos (120 segundos). Veja se ele dá sinal de vida.

  • Posts no fórum: 331

26/abr/2014 14:15:42 via Web

Olair Junior

Lucas Silva

Cara, consegui!!! :) Só que nesse terceiro passo: "3- Renomeie a imagem da Recovery que você baixou para recovery.img", no lugar de renomear para "recovery.img", deve-se renomear assim: "recovery", só no cmd que precisa colocar a extensão ".img". Mas muito obrigado pela ajuda!! :D

Fico feliz por você ter conseguido. E a observação da nomeação do arquivo foi um detalhe importante. Parabéns. Está progredindo. :)

Lucas Silva

Vlw cara. :)

  • Posts no fórum: 1.239

26/abr/2014 18:10:48 via Web

Tutorial atualizado com o Markdown.

▂ ▃ ▅ ▆ █
-- Nexus 5 / D821
-- AOSPA 4+
--- SoundCloud
--- YouTube

Leia o tutorial por inteiro duas vezes antes de executá-lo, atento a qualquer mínimo detalhe e aos arquivos baixados!

  • Posts no fórum: 6

27/abr/2014 23:56:12 via Web

boa noite a todos, nao sei se estou no lugar certo mas procurei algo relacionado ao titulo para xperia m dual e apos uma semana ninguem me respondeu. Mas gostaria de dizer que consegui realizar o bootloader e rooting no meu aparelho. agora vou tentar instalar alguma rom que reconheça 2 chip.

  • Posts no fórum: 10

30/abr/2014 23:08:57 via Web

obg consegui ! parece complicado mas não é !! apenas é necessário atenção e paciência... e vc tem que digitar se copiar e colar vai dar erro... eu perdi um tempão por causa disso! kkk mesmo assim muito obg showw

— alterado em 13/mai/2014 18:03:53

  • Posts no fórum: 26

1/mai/2014 15:14:26 via Web

Gente alguém sabe se eu fizere root por outro aplicativo como o unlock root ou o farmroot eu perco as atualizações via OTA???