Motorola Moto E — [Mod][Unofficial][v28] MultiROM para o Moto E [Estável]

  • Respostas:53
  • AbertoStickySem resposta
  • Posts no fórum: 2.046

15/set/2014 17:56:42 via Web

Voce pode me mostrar o dialogo original? Qualquer coisa tu pode me enviar por email, para mim ter certeza que é todas as linhas assert do script update.

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.

  • Posts no fórum: 2.046

15/set/2014 18:03:52 via Web

Removi, agora só resta testar aqui e ver no que da ....

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.

  • Posts no fórum: 432

15/set/2014 18:54:31 via App

Laíre S.

Jonas D.

either remove assert checking from the zip updater script
Next time do some search before asking these things , these are pretty small thing's you should know before flashing.

Ele disse isso.

se for só remover as linhas é facil, só não sei se vai trabalhar apos isso, vou ver se consigo remover sem extrair e tentar no meu, se acorrer tudo be, te mando o arquivo ou a forma de fazer.

Eu removi, mas não consegui criar o zip de novo. Usei o APP ZipMe, mas não funcionou.

Motorola Moto E - XT1025
• CyanogenMod 13.0 (MM 6.0.1)
• TWRP 2.8.7

  • Posts no fórum: 2.046

16/set/2014 1:52:09 via Web

eu tirei as linhas do assert, ficando assim, porem o zip instala, mais não mostra o MultiROM. E como se na verdade não instalasse.

ui_print("Installing MultiROM for condor");

# Assert check for appropriate device is added during build,
# see ../make_updater_script.sh and ../Android.mk

show_progress(1.00000, 10);

ui_print("Extracting binaries...");
run_program("/sbin/busybox", "mount", "/data");

delete_recursive("/tmp/multirom");
run_program("/sbin/busybox", "mkdir", "/tmp/multirom");
package_extract_dir("multirom", "/tmp/multirom/");
package_extract_dir("scripts", "/tmp/");

set_perm(0, 0, 0777, "/tmp/multirom/busybox");
set_perm(0, 0, 0777, "/tmp/bbootimg");
set_perm(0, 0, 0777, "/tmp/extract_multirom.sh");
set_perm(0, 0, 0777, "/tmp/inject_boot.sh");

ui_print("Injecting boot image...");

ui_print("Cleaning up...");
delete_recursive("/tmp/boot");
delete_recursive("/tmp/multirom");
delete("/tmp/bbootimg");
delete("/tmp/bootimg.cfg");
delete("/tmp/initrd.img");
delete("/tmp/zImage");
delete("/tmp/boot.img");
delete("/tmp/dtb.img");
delete("/tmp/second.img");
delete("/tmp/newboot.img");
delete("/tmp/extract_multirom.sh");
delete("/tmp/inject_boot.sh");
delete("/tmp/bootdev");
delete("/tmp/rd_addr");
delete("/tmp/use_mrom_fstab");

ui_print("Installation complete!");

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.

  • Posts no fórum: 432

16/set/2014 3:20:54 via App

Laíre S.

eu tirei as linhas do assert, ficando assim, porem o zip instala, mais não mostra o MultiROM. E como se na verdade não instalasse.

ui_print("Installing MultiROM for condor");

# Assert check for appropriate device is added during build,
# see ../make_updater_script.sh and ../Android.mk

show_progress(1.00000, 10);

ui_print("Extracting binaries...");
run_program("/sbin/busybox", "mount", "/data");

delete_recursive("/tmp/multirom");
run_program("/sbin/busybox", "mkdir", "/tmp/multirom");
package_extract_dir("multirom", "/tmp/multirom/");
package_extract_dir("scripts", "/tmp/");

set_perm(0, 0, 0777, "/tmp/multirom/busybox");
set_perm(0, 0, 0777, "/tmp/bbootimg");
set_perm(0, 0, 0777, "/tmp/extract_multirom.sh");
set_perm(0, 0, 0777, "/tmp/inject_boot.sh");

ui_print("Injecting boot image...");

ui_print("Cleaning up...");
delete_recursive("/tmp/boot");
delete_recursive("/tmp/multirom");
delete("/tmp/bbootimg");
delete("/tmp/bootimg.cfg");
delete("/tmp/initrd.img");
delete("/tmp/zImage");
delete("/tmp/boot.img");
delete("/tmp/dtb.img");
delete("/tmp/second.img");
delete("/tmp/newboot.img");
delete("/tmp/extract_multirom.sh");
delete("/tmp/inject_boot.sh");
delete("/tmp/bootdev");
delete("/tmp/rd_addr");
delete("/tmp/use_mrom_fstab");

ui_print("Installation complete!");

Vou mandar isso pro Percy. Mas ele parou de responder.

Motorola Moto E - XT1025
• CyanogenMod 13.0 (MM 6.0.1)
• TWRP 2.8.7

  • Posts no fórum: 2.046

16/set/2014 3:47:25 via Web

Melhor deixar ele sussegar um pouco, ele ta quebrando a Cabeça com um Compilação da CM para o Moto E, tudo isso que a motorola não atualizou os Drivers para conexão sem fio no Android 4.4.4.

— alterado em 16/set/2014 3:47:55

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.

  • Posts no fórum: 432

16/set/2014 3:52:01 via App

O Percy fez um zip pra mim. kkkkk
O povo não aguenta minha chatice. Vou testar.

— alterado em 16/set/2014 4:06:08

Motorola Moto E - XT1025
• CyanogenMod 13.0 (MM 6.0.1)
• TWRP 2.8.7

  • Posts no fórum: 432

16/set/2014 4:18:30 via App

O Percy upou esse zip pra mim.

http://d-h.st/IWs

Eu instalei o kernel pelo Flashify, depois entrei no TWRP e instalei esse zip, mas quando reiniciou não abriu o menu do MultiRom e sim o boot normal e ligou.

Motorola Moto E - XT1025
• CyanogenMod 13.0 (MM 6.0.1)
• TWRP 2.8.7

  • Posts no fórum: 2.046

16/set/2014 4:21:24 via Web

Cara porque esse teu tem as partições tão difteretes, coitado do Percy, lá se for mais um status de estável :'(

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.

  • Posts no fórum: 2.046

16/set/2014 4:22:29 via Web

Se bem que é estável, apenas não funciona no XT 1025 :D

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.

  • Posts no fórum: 432

16/set/2014 4:53:49 via App

Laíre S.

Se bem que é estável, apenas não funciona no XT 1025 :D

Queria muito isso. Bem que eu tentei comprar o modelo sem TV Digital na internet, mas tava dando problema no cartão e tive que ir numa loja física e só existe o XT1025 em lojas físicas.

Motorola Moto E - XT1025
• CyanogenMod 13.0 (MM 6.0.1)
• TWRP 2.8.7

  • Posts no fórum: 2.046

16/set/2014 4:59:42 via Web

Jonas D.

Laíre S.

Se bem que é estável, apenas não funciona no XT 1025 :D

Queria muito isso. Bem que eu tentei comprar o modelo sem TV Digital na internet, mas tava dando problema no cartão e tive que ir numa loja física e só existe o XT1025 em lojas físicas.

Verdade, mas ao menos tu usa tv?

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.

  • Posts no fórum: 27

16/set/2014 5:30:03 via App

Pessoal tenho um 1025 se o problema fosse as partições diferentes acho que seria muito simples de resolver mudando o dir* não estudei isso mais acho que alguém teria pensado nisso, o fato de o software pedir para remover tais linhas significa gambiarra e que ele já estava programado para ter esse comportamento sendo assim ou teríamos que ter uma equipe de desenvolvedores com o código fonte de todos os arquivos e software usados ou contatar o desenvolvedor e pedir uma ajuda...

  • Posts no fórum: 432

16/set/2014 6:04:00 via App

Laíre S.

Jonas D.

Laíre S.

Se bem que é estável, apenas não funciona no XT 1025 :D

Queria muito isso. Bem que eu tentei comprar o modelo sem TV Digital na internet, mas tava dando problema no cartão e tive que ir numa loja física e só existe o XT1025 em lojas físicas.

Verdade, mas ao menos tu usa tv?

Ninguém usa TV. KKKKK
TV em smartphone é a coisa mais inútil do mundo. kk
Nunca nem testei, nem sei se funciona. kkk

— alterado em 16/set/2014 6:04:42

Motorola Moto E - XT1025
• CyanogenMod 13.0 (MM 6.0.1)
• TWRP 2.8.7

  • Posts no fórum: 432

16/set/2014 6:06:09 via App

Diego

Pessoal tenho um 1025 se o problema fosse as partições diferentes acho que seria muito simples de resolver mudando o dir* não estudei isso mais acho que alguém teria pensado nisso, o fato de o software pedir para remover tais linhas significa gambiarra e que ele já estava programado para ter esse comportamento sendo assim ou teríamos que ter uma equipe de desenvolvedores com o código fonte de todos os arquivos e software usados ou contatar o desenvolvedor e pedir uma ajuda...

Eu contatei ele, foi ele que mandou fazer isso e ainda criou um zip pra mim. Mesmo assim não funcionou.
Mandei mensagem pra ele, mas até não respondeu.
O cara tá portando o CM11 totalmente funcional para o nosso Moto E.

— alterado em 16/set/2014 6:10:09

Motorola Moto E - XT1025
• CyanogenMod 13.0 (MM 6.0.1)
• TWRP 2.8.7

  • Posts no fórum: 2.046

16/set/2014 23:49:29 via Web

Yuri Castro

Deu certo no meu XT1025, estou usando stock e CM11. Belo post.
:)

Thanks for suppot man!! ...Yuri, muito obrigado por comentar e nos deixar informados, pois não estava funcional para o Moto E TV XT1025, e agora está, voce fez algo alem de fazer como ensinei na pagina 1? Desde ja agradeço!

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.

  • Posts no fórum: 19

17/set/2014 3:30:55 via Web

Laíre S.

Yuri Castro

Deu certo no meu XT1025, estou usando stock e CM11. Belo post.
:)

Thanks for suppot man!! ...Yuri, muito obrigado por comentar e nos deixar informados, pois não estava funcional para o Moto E TV XT1025, e agora está, voce fez algo alem de fazer como ensinei na pagina 1? Desde ja agradeço!

Bom, a primeira vez que eu tentei não deu certo, então tive que instalar a stock novamente. Depois de ter instalado o Recovery e Root novamente, dei flash na Kernel stook pelo Flashify e fui tentar instalar o zip do Multirom, sem sucesso, então dei o flash no Recovery Multirom novamente pelo Flashify. Assim, já com o Recovery modificado com a opção do Multirom, consegui instalar o zip. Depois foi só ir em Avanced > MultiROM > AddROM. Instalei a CM11 e funcionou perfeitamente. :)
O único inconveniente é que depois que cheguei em casa a CM11 não quis mais conectar ao meu Wi-fi, sendo que no meu trabalho se conectou perfeitamente. (Sabe por quê?)

Obrigado! ;)

  • Posts no fórum: 2.046

17/set/2014 3:38:52 via Web

Acabei de postar uma Compilação da CM11, feita pelo percy, e esta perfeita, único problema que a Motorola não atualizou os Drivers para rede sem fio, então, o wifi acaba não conectando automaticamente com rede publicas, que na verdade é o que usamos em casa, por maior segurança, dai voce precisar mudar em opções avançadas do Wifi para estático, depois faço um tuto e acrescento os detalhes la no tutorial da ROM mencionada.

"Antes de realizar qualquer procedimento, leia, aprenda, entenda, tire as dúvidas lendo, execute, se tiver problemas leia as experiências dos outros usuários, e re-execute, persista e nunca desista!"

Novo no fórum? Leia as regras de publicações, elas vão te ajudar muito na hora de postar um novo tópico.