Sony Xperia Z1 — [AJUDA] Problemas com a câmera.

  • Respostas:25
  • AbertoNão stickySem resposta
  • Posts no fórum: 364

16/mar/2015 15:12:10 via Web

Bom dia a todos.

Há um tempo, venho enfrentando problemas com a câmera do meu Xperia Z1.
Em muitas vezes recebo a mensagem "Câmera não está disponível" (ou algo assim), ou a imagem congela na tela, e é preciso bloquear, e desbloquear a tela para voltar a reutilizar o aparelho, sendo que a imagem não é capturada.

Ontem, dei uma procurada, e achei alguns tópicos até mesmo aqui, porém, que não se enquadravam com meu problema. No que vi, usuários estavam enfrentando problemas com o modo Auto. Superior, e ao utilizar o modo Manual, nada ocorria. Eu já tenho o problema inverso. Uso mais o modo Manual, e é esse que está me dando dor de cabeça, sendo que quando um para de funcionar, o outro também para.

Além do maldito problema de congelamento, e da mensagem de erro, por muitas vezes ao abrir a câmera, depois de todos esses problemas, não é exibida imagem alguma, apenas uma tela preta, com os botões. É possível capturar imagens, capturando uma imagem preta.

Quando esse problema ocorre, apenas a reinicialização do aparelho corrige. Já os outros problemas, não encontrei solução, e, por incrível que pareça, qualquer um deles ocorre apenas quando preciso da câmera com urgência/muita necessidade.

Já forcei parada, limpei dados, e também enfrento problemas utilizando outros apps de câmera.

O que pode ser??

  • Posts no fórum: 113

16/mar/2015 15:36:38 via App

Leonardo Alves

Bom dia a todos.

Há um tempo, venho enfrentando problemas com a câmera do meu Xperia Z1.
Em muitas vezes recebo a mensagem "Câmera não está disponível" (ou algo assim), ou a imagem congela na tela, e é preciso bloquear, e desbloquear a tela para voltar a reutilizar o aparelho, sendo que a imagem não é capturada.

Ontem, dei uma procurada, e achei alguns tópicos até mesmo aqui, porém, que não se enquadravam com meu problema. No que vi, usuários estavam enfrentando problemas com o modo Auto. Superior, e ao utilizar o modo Manual, nada ocorria. Eu já tenho o problema inverso. Uso mais o modo Manual, e é esse que está me dando dor de cabeça, sendo que quando um para de funcionar, o outro também para.

Além do maldito problema de congelamento, e da mensagem de erro, por muitas vezes ao abrir a câmera, depois de todos esses problemas, não é exibida imagem alguma, apenas uma tela preta, com os botões. É possível capturar imagens, capturando uma imagem preta.

Quando esse problema ocorre, apenas a reinicialização do aparelho corrige. Já os outros problemas, não encontrei solução, e, por incrível que pareça, qualquer um deles ocorre apenas quando preciso da câmera com urgência/muita necessidade.

Já forcei parada, limpei dados, e também enfrento problemas utilizando outros apps de câmera.

O que pode ser??

Vamos lá, primeiro nos dê mais informações, a câmera é a Stock do Android ou não? Qual sua versão de Android? Desde quando isso vem acontecendo?

Smartphone: Lenovo VIBE K5
ROM: Custom Stock 5.1.1
Kernel: Padrão
Versão do Android: 5.1.1 Lollipop
Acesso Root: Sim
Custom Recovery: TWRP 3.0.2.0

Te ajudei? Agradeça clicando em Obrigado!

  • Posts no fórum: 364

16/mar/2015 16:09:17 via Web

A câmera é o aplicativo padrão da Sony. Como dito, outros apps de câmera/fotografia mantém o problema, caso ele venha a acontecer.

Como visto no meu perfil, o aparelho roda o KitKat 4.4.4, sem root, ou quaisquer modificações.

Vem acontecendo já há alguns meses, amigo.

  • Posts no fórum: 2

18/mar/2015 12:53:40 via Web

Eu já tive este problema com o meu e forçando uma atualização ele voltou ao normal, você já tentou fazer isso?

Quanto ao fazer, existem alguns sites que falam sobre isso por ai, apenas coloque no Google forçar atualização e o seu modelo que talvez se resolva assim como eu.

Como estão saindo muitas atualizações, as vezes ocorrem problemas na transferência de arquivos!

Rodrigo Colombo
www.tudoparaandroid.com.br
www.adkom.com.br
Redator e Empreendedor Digital

  • Posts no fórum: 364

18/mar/2015 15:33:33 via Web

Gean M Gonçalves

Utilize apenas o modo de disparo "Manual". Geralmente o "Auto Superior" trava mesmo, além de tirar fotos com apenas 8MP.

Amigo, leu o meu post?
O problema ocorre MUITO mais com o modo Manual, que é o que mais utilizo...

  • Posts no fórum: 364

18/mar/2015 15:35:15 via Web

Rodrigo Colombo - Tudo para Android Blog

Eu já tive este problema com o meu e forçando uma atualização ele voltou ao normal, você já tentou fazer isso?

Quanto ao fazer, existem alguns sites que falam sobre isso por ai, apenas coloque no Google forçar atualização e o seu modelo que talvez se resolva assim como eu.

Como estão saindo muitas atualizações, as vezes ocorrem problemas na transferência de arquivos!

Rodrigo Colombo
www.tudoparaandroid.com.br
www.adkom.com.br
Redator e Empreendedor Digital

Rodrigo, obrigado!
Como a atualização do Lollipop para o meu aparelho deve chegar nas próximas semanas, vou esperar pra ver se ainda vou "passar raiva".
Porém, procurei sobre o que disse, e não encontrei nada :/

  • Posts no fórum: 704

20/mar/2015 6:14:32 via Web

já tive o mesmo problema que você, igualzinho, resolvi 100% com atualização do kitkat 4.4.4, numero de compilação 14.4.A.0.157.

seu android é 4.4.4 mas e as atualizações de segurança, bugs e drivers da sony estão ok ?!

para saber, é a ultima informação quando se abre as informações sobre o aparelho... eu fiz a atualização pelo app da sony e logo depois disso fiz um reset de fabrica no aparelho, agora a camera está 100%

--- EDIT ---

Hoje uso o android 4.4.4 build number 14.A.4.0.157 com Root + dual recovery + módulo xposed. aparelho tá 100%.

— alterado em 20/mar/2015 6:16:10

Devices:
Motorola X Play - Stock android 6.0
Motorola Moto 360 - Stock android wear

Broken:
Sony Xperia Z1 C6903 - Stock Lollipop 5.1.1 - Build 14.6.A.0.368

  • Posts no fórum: 364

20/mar/2015 12:24:02 via Web

Ricardo R.

já tive o mesmo problema que você, igualzinho, resolvi 100% com atualização do kitkat 4.4.4, numero de compilação 14.4.A.0.157.

seu android é 4.4.4 mas e as atualizações de segurança, bugs e drivers da sony estão ok ?!

para saber, é a ultima informação quando se abre as informações sobre o aparelho... eu fiz a atualização pelo app da sony e logo depois disso fiz um reset de fabrica no aparelho, agora a camera está 100%

--- EDIT ---

Hoje uso o android 4.4.4 build number 14.A.4.0.157 com Root + dual recovery + módulo xposed. aparelho tá 100%.

Ricardo, o meu consta na 14.4.A.0.108.
Para atualizar, somente pelo PC Companion da Sony, é isso?
Perderei algum arquivo/dado (pergunto pois gosto da organização nas minhas músicas, e sempre que atualizei algum dispositivo Sony, bagunçou minha biblioteca)?

  • Posts no fórum: 704

23/mar/2015 5:42:12 via Web

sim, pelo pc companion, tenta antes ver pel oapp de atualização da sony, que tem no celular, agora se vai mexer com os dados eu não sei, pois sempre que eu atualizo, já faço um reset total pra não ter futuros problemas...

Devices:
Motorola X Play - Stock android 6.0
Motorola Moto 360 - Stock android wear

Broken:
Sony Xperia Z1 C6903 - Stock Lollipop 5.1.1 - Build 14.6.A.0.368

  • Posts no fórum: 364

27/mar/2015 13:21:25 via Web

Amigos, mais um agravante:

Ao filmar, tanto no Auto. Superior quanto no Manual, a imagem congela, assim que inicio a gravação.
O vídeo é gravado normalmente, mas não posso controlar o que está sendo filmado, fora que, o resultado dá algumas engasgadas.

Alguém sabe uma solução?

Ricardo, o problema pode estar ligado aos demais, e assim, à mesma atualização?

  • Posts no fórum: 704

27/mar/2015 19:46:03 via Web

Leonardo Alves

Amigos, mais um agravante:

Ao filmar, tanto no Auto. Superior quanto no Manual, a imagem congela, assim que inicio a gravação.
O vídeo é gravado normalmente, mas não posso controlar o que está sendo filmado, fora que, o resultado dá algumas engasgadas.

Alguém sabe uma solução?

Ricardo, o problema pode estar ligado aos demais, e assim, à mesma atualização?

nunca vi esse problema do vídeo, sim pode estar ligado, a sony fez muitos upgrades e correções em seus drivers de camera, durante todos os updates, quem comprou o aparelho perto de seu lançamento, sempre reclamou de erros, e com o tempo a sony foi corrigindo, o certo mesmo é fazer o seguinte:

Backup de tudo o que você tem nele > reset de fabrica, TODAS as atualizações possíveis > Reset de fabrica de novo > Testar o aparelho com os apps ORIGINAIS como se tivesse acabado de comprar, assim da pra tirar da cabeça outra duvida que é se tem algum app interferindo.

caso não de certo e continue o erro, ai da pra pensar em acionar alguma garantia ou outros meios...

Devices:
Motorola X Play - Stock android 6.0
Motorola Moto 360 - Stock android wear

Broken:
Sony Xperia Z1 C6903 - Stock Lollipop 5.1.1 - Build 14.6.A.0.368

  • Posts no fórum: 364

30/mar/2015 13:40:28 via Web

Ricardo R.

Leonardo Alves

Amigos, mais um agravante:

Ao filmar, tanto no Auto. Superior quanto no Manual, a imagem congela, assim que inicio a gravação.
O vídeo é gravado normalmente, mas não posso controlar o que está sendo filmado, fora que, o resultado dá algumas engasgadas.

Alguém sabe uma solução?

Ricardo, o problema pode estar ligado aos demais, e assim, à mesma atualização?

nunca vi esse problema do vídeo, sim pode estar ligado, a sony fez muitos upgrades e correções em seus drivers de camera, durante todos os updates, quem comprou o aparelho perto de seu lançamento, sempre reclamou de erros, e com o tempo a sony foi corrigindo, o certo mesmo é fazer o seguinte:

Backup de tudo o que você tem nele > reset de fabrica, TODAS as atualizações possíveis > Reset de fabrica de novo > Testar o aparelho com os apps ORIGINAIS como se tivesse acabado de comprar, assim da pra tirar da cabeça outra duvida que é se tem algum app interferindo.

caso não de certo e continue o erro, ai da pra pensar em acionar alguma garantia ou outros meios...

Continuando assim, não sei se vou aguentar com ele até o fim desse ano/começo de 2016...
Vou esperar sair o Lollipop, e já resolvo tudo com uma tacada só.

Obrigado pela ajuda, Ricardo.

  • Posts no fórum: 704

31/mar/2015 7:08:17 via Web

Leonardo Alves

Ricardo R.

Leonardo Alves

Amigos, mais um agravante:

Ao filmar, tanto no Auto. Superior quanto no Manual, a imagem congela, assim que inicio a gravação.
O vídeo é gravado normalmente, mas não posso controlar o que está sendo filmado, fora que, o resultado dá algumas engasgadas.

Alguém sabe uma solução?

Ricardo, o problema pode estar ligado aos demais, e assim, à mesma atualização?

nunca vi esse problema do vídeo, sim pode estar ligado, a sony fez muitos upgrades e correções em seus drivers de camera, durante todos os updates, quem comprou o aparelho perto de seu lançamento, sempre reclamou de erros, e com o tempo a sony foi corrigindo, o certo mesmo é fazer o seguinte:

Backup de tudo o que você tem nele > reset de fabrica, TODAS as atualizações possíveis > Reset de fabrica de novo > Testar o aparelho com os apps ORIGINAIS como se tivesse acabado de comprar, assim da pra tirar da cabeça outra duvida que é se tem algum app interferindo.

caso não de certo e continue o erro, ai da pra pensar em acionar alguma garantia ou outros meios...

Continuando assim, não sei se vou aguentar com ele até o fim desse ano/começo de 2016...
Vou esperar sair o Lollipop, e já resolvo tudo com uma tacada só.

Obrigado pela ajuda, Ricardo.

Beleza, creio ser mais pratico heheh, sem problemas, qualquer coisa estamos ai, pena o forum do Z1 ser tão parado por aqui, no xda ele bomba um pouquinho

Devices:
Motorola X Play - Stock android 6.0
Motorola Moto 360 - Stock android wear

Broken:
Sony Xperia Z1 C6903 - Stock Lollipop 5.1.1 - Build 14.6.A.0.368

  • Posts no fórum: 35

6/abr/2015 13:46:32 via Web

Leandro, o problema que você tem eu tinha exatamente igual no Z1 Compact. Tanto no Manual como no Auto, a tela simplesmente congelava e a câmera só voltava a funcionar depois de bloquear/desbloquear a tela... Tentei de tudo, formatei o celular, limpei o cache, mas a única coisa que funcionou foi a atualização 14.4.A.0.157, como o Ricardo Ragazzini comentou anteriormente. Estranho você não ter recebido ainda... O meu recebeu ainda em novembro passado. Após a atualização o problema de congelamento nunca mais aconteceu, em nenhum dos modos, apenas a mensagem de "câmera não disponível" voltou a aparecer umas 3 ou 4 vezes (foi só isso mesmo, por sorte!) e é só dar um "ok" e abrir novamente que funciona. Com certeza o teu Z1 vai ficar 100% depois do Lollipop :D

  • Posts no fórum: 364

6/abr/2015 17:12:44 via Web

Pois então, não recebi a atualização pelo aparelho. Tenho que atualizar pelo software de desktop.
Porém, há uma chance de bagunçar meus dados (músicas, etc), coisa que me irrita muito.
Como já há uma chance disso acontecer, também, quando for atualizar para o Lollipop, nem vou perder tempo duas vezes, vou fazer tudo de uma tacada só. Haha.

Obrigado pela ajuda, Luis!
Abraços!

  • Posts no fórum: 35

6/abr/2015 19:24:36 via Web

Pois é, essa questão de bagunçar tudo também me irrita haha. É, agora que o Lollipop já está quase aí (tomara né!) é uma boa esperar.

Imagina, por nada! Agora é só torcer pra que saia o quanto antes esse Android... A espera é sofrível haha. Abração!

  • Posts no fórum: 21

12/abr/2015 16:06:29 via Web

Muito ruim esses problemas com a câmera, sempre aparecendo câmera indisponível, as vezes quando eu viro o celular pra tirar foto deitado e depois coloco ele em pé de novo e tiro foto, ele continua como se estivesse deitado e as fotos saem todas viradas e só volta ao normal se reiniciar o celular, as vezes também quando vou tirar uma foto a câmera trava e só destrava se bloquear e desbloquear a tela e não capta foto nenhuma. Esperando a atualização pro Lollipop pra ver se resolve esses problemas.

  • Posts no fórum: 364

13/abr/2015 14:21:37 via Web

Então, Eduardo.
Como disseram acima, há uma atualização disponível pelo software da Sony para Desktop.

Eu, como um usuário (preguiçoso), pretendo esperar o Lollipop, pra fazer ambas as atualizações de uma vez, e não ter que me preocupar com quaisquer "bagunças" nas minhas músicas, etc.

Porém, esse problema da "câmera deitada" não enfrentei, até hoje.

Abraços.

  • Posts no fórum: 704

14/abr/2015 17:28:14 via App

Estou com menos de 24hrs de lollipop, a camera está fenomenal, e fazendo videos fullhd a 60 fps. O tempo de foco é ridiculamente pequeno, melhoraram muito

Devices:
Motorola X Play - Stock android 6.0
Motorola Moto 360 - Stock android wear

Broken:
Sony Xperia Z1 C6903 - Stock Lollipop 5.1.1 - Build 14.6.A.0.368