Motorola Moto X (2014) — Problemas no GPS do Moto X XT-1097

  • Respostas:14
  • AbertoNão stickySem resposta
  • Posts no fórum: 9

29/abr/2015 1:27:51 via Web

Galera, boa noite !
Estou com um problema no gps que eu nao sei se é bug(software) ou hardware. O que acontece: Quando é para navegar normal, só para ver a sua localização no mapa, ele funciona, meio desnorteado mas funciona, o problema é quando vai traçar uma rota.
Quando eu vou traçar uma rota nele, no Here Maps por exemplo, ele só fica "aguardando GPS" e nao sai disso.
Alguem me ajuda?

  • Posts no fórum: 23

29/abr/2015 14:04:54 via Web

Caio Teixeira

Galera, boa noite !
Estou com um problema no gps que eu nao sei se é bug(software) ou hardware. O que acontece: Quando é para navegar normal, só para ver a sua localização no mapa, ele funciona, meio desnorteado mas funciona, o problema é quando vai traçar uma rota.
Quando eu vou traçar uma rota nele, no Here Maps por exemplo, ele só fica "aguardando GPS" e nao sai disso.
Alguem me ajuda?

como está configurado seu gsp? tenta configurar para alta precisão.
além disso, como outros apps se comportam? Por exemplo google maps e Waze

  • Posts no fórum: 9

2/mai/2015 12:59:39 via Web

Em todas as configurações ele fica assim. E em todos os aplicativos (Waze, Google Maps e Maps HERE) ficam com esse problema.

  • Posts no fórum: 1

30/mai/2015 2:29:56 via Web

Também estou com este problema, no meu moto x primeira geração. Ele fica procurando o GPS. Uso o android 4.4.4, queria saber se é software, seleciono as opções de fábrica, ele continua da mesma forma.

  • Posts no fórum: 9

1/jun/2015 14:35:33 via Web

marcos

Também estou com este problema, no meu moto x primeira geração. Ele fica procurando o GPS. Uso o android 4.4.4, queria saber se é software, seleciono as opções de fábrica, ele continua da mesma forma.

Já fiz isso também. Mesmo com as configurações de fábrica ele não funciona, o pessoal de um outro fórum me disse que isso é problema de hardware e que eu tinha que levar na Motorola.

  • Posts no fórum: 1

1/jul/2015 4:22:14 via Web

O meu esta acontecendo a mesma coisa, li em outros fóruns que o problema é ligar ele como 3g da tim e o gps ao mesmo tempo!
A solução é passar para rede 2g e ativar o gps ae ele volta ao normal, testei e funcionou!
No fórum li que em outras operadoras estão funcionando normalmente!

  • Posts no fórum: 2

14/set/2015 1:19:38 via Web

O meu Moto X segunda geração está com esse problema também. Quando uso o GPS com o 3G ligado, o sinal fica indo e voltando, e a localização fica oscilando para vários lugares diferentes do lugar onde realmente estou. Só estou conseguindo usá-lo sem problemas quando deixo na rede 2G ou sem rede de dados, usando só a localização do GPS mesmo.

Obs: meu chip é da VIVO, plano empresa.

  • Posts no fórum: 1

9/mar/2016 21:09:38 via Web

Sim, pelo que vi na internet é um BUG no Moto X2 e em alguns Moto G, parece uma incompatibilidade com nossas redes 3G e 4G brasileiras que fazem com que o GPS não funcione corretamente, ele fica perdendo sinal e travando quando navega, o jeito até agora é colocar na 2G mesmo e ser feliz. Isso serve tanto pra GPS online quando offline. Não sei se terá alguma solução, e acredito que não, pois a motorola afirmou isso já faz 1 ano e ainda não conseguiram corrigir.

  • Posts no fórum: 1

24/jul/2016 22:28:15 via Web

Para muitos dispositivos da Motorola (e algumas outras marcas) o GPS não funciona quando conectado a uma rede 3G. Não tem problema quando conectado a 2g, 4g, WiFi, dados desativados ou sem rede. A razão é que o Google oferece o Android com um arquivo gps.conf inválido, para dispositivos com Android puro ou quase puro (como é o caso da Motorola). Para este caso siga os passos abaixo:

É necessário substituir /system/etc/gps.conf por uma configuração válida. Pesquisar no Google por "Google gps.conf" (sem aspas). Você vai precisar de root. Não pude colocar o arquivo inteiro aqui no post porque tem links e não é permitido.

Você também precisa verificar as configurações de APN, e adicionar agps e supl se não existir.

Para um melhor desempenho alterar os servidores NTP para os mais próximos (Brasil e América do Sul em nosso caso), pesquise no Google por NTP Server List.

  • Posts no fórum: 18

25/jul/2016 2:28:46 via Web

Alexandro Simioni

Para muitos dispositivos da Motorola (e algumas outras marcas) o GPS não funciona quando conectado a uma rede 3G. Não tem problema quando conectado a 2g, 4g, WiFi, dados desativados ou sem rede. A razão é que o Google oferece o Android com um arquivo gps.conf inválido, para dispositivos com Android puro ou quase puro (como é o caso da Motorola). Para este caso siga os passos abaixo:

É necessário substituir /system/etc/gps.conf por uma configuração válida. Pesquisar no Google por "Google gps.conf" (sem aspas). Você vai precisar de root. Não pude colocar o arquivo inteiro aqui no post porque tem links e não é permitido.

Você também precisa verificar as configurações de APN, e adicionar agps e supl se não existir.

Para um melhor desempenho alterar os servidores NTP para os mais próximos (Brasil e América do Sul em nosso caso), pesquise no Google por NTP Server List.

Caro amigo Alexandro Simioni,

Você é o cara, deu super certo no meu Moto G1, fiz todos os passos que você citou.
Muito grato pela sua ajuda.

— alterado em 25/jul/2016 2:30:24

  • Posts no fórum: 3

5/ago/2016 15:21:16 via Web

Amigo, percebi com o colega abaixo que fazer essas configurações pode dar certo, mas alguns passos não entendi direito.

"Você também precisa verificar as configurações de APN, e adicionar agps e supl se não existir.
Para um melhor desempenho alterar os servidores NTP para os mais próximos (Brasil e América do Sul em nosso caso), pesquise no Google por NTP Server List."

Outra coisa, eu utilizo o programa "GPS Status & Toolbox" e sempre quando abro, ele baixa sempre uma atualização de Dados A-GPS XTRA (dados de auxílio ao GPS) para acelerar ele, informações de satélite atualizados, posições e etc...

Isso nunca me causou qualquer problema.

Me parece realmente que meu Cel está retardando, ora conecta, oras cai, oras volta e assim vai indo.

Pode me auxiliar?

  • Posts no fórum: 18

5/ago/2016 17:51:39 via Web

O problema voltou, durou apenas um dia. Muito estranho.

23/08
Apos algumas tentativas de mudar o gps.config, deu certo com essa configuração: docs.google.com/document/d/12JGuF553-Yswh7IRhAZ77I0tpfyuTb0N9SpJ7_GygGE/edit#!

— alterado em 23/ago/2016 5:10:46

  • Posts no fórum: 1

26/set/2016 20:23:33 via Web

Amigo, estava desesperado com meu GPS Tentei de tudo e não ia nem por reza brava. Segui os passos no canal do youtube do nosso amigo JonathanDroid e deu tudo certo! Segue o Link watch?v=oSRKnV9PgWk
Tive que colocar só o final pq o site aqui não permite links externos!
Abraços