Motorola Moto G (2014) — [MOD][NÃO OFICIAL] MultiROM v32 para Moto G 2014 (Titan)

  • Respostas:264
  • AbertoNão stickySem resposta
  • Posts no fórum: 2.976

20/jun/2015 15:24:39 via App

Diego Jonathan

Emerson

Diego Jonathan

Já instalei aqui, agora só falta instalar o kernel.
Uma dúvida, se eu instalar o kernel ele vai mudar o kernel da ROM que estou usando automaticamente né isso?
Pq eu não queria mudar o kernel stock dela.

Vai ter que mudar pra um com suporte ao Kexec Hardboot se quiser usar o multirom.

Blz, entendi, aii é só reiniciar no recovery e dá flash nele normal é?

Sim, ai pra instalar as ROMs secundarias é só fazer como no tutorial.

Smartphone: Moto G 2014 (XT1069) - Codinome: Titan
Sistema: Marshmallow STOCK
Kernel: Stock M
Versão do Android: 6.0

  • Posts no fórum: 1.715

20/jun/2015 15:39:11 via App

Emerson

Diego Jonathan

Emerson

Diego Jonathan

Já instalei aqui, agora só falta instalar o kernel.
Uma dúvida, se eu instalar o kernel ele vai mudar o kernel da ROM que estou usando automaticamente né isso?
Pq eu não queria mudar o kernel stock dela.

Vai ter que mudar pra um com suporte ao Kexec Hardboot se quiser usar o multirom.

Blz, entendi, aii é só reiniciar no recovery e dá flash nele normal é?

Sim, ai pra instalar as ROMs secundarias é só fazer como no tutorial.

blz, valeu!

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

  • Posts no fórum: 171

20/jun/2015 20:16:26 via App

Deu certinho aqui !! Vlw Emerson por estar sempre trazendo ótimos conteúdos para a gente :D

Dispositivo: Moto G 2013 (XT1034) Codinome: Falcon
ROM: Lineage os 14.1
Kernel: Stock
Versão Android: 7.1.1
Custom Recovery: TWRP 3.1.0.0
ROOT: Nao
Xposed: Nao

Tudo o que um sonho precisa para ser realizado é alguém que acredite que ele possa ser realizado.

  • Posts no fórum: 1.715

21/jun/2015 2:41:04 via Web

Emerson fiz tudo certinho, na hora de instalar outra rom dá um erro relacionado ao TWRP.

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

  • Posts no fórum: 2.976

21/jun/2015 2:43:53 via App

Diego Jonathan

Emerson fiz tudo certinho, na hora de instalar outra rom dá um erro relacionado ao TWRP.

Qual erro? Instalou o TWRP modificado, né?

Na Instalação da primária ou secundaria?

Smartphone: Moto G 2014 (XT1069) - Codinome: Titan
Sistema: Marshmallow STOCK
Kernel: Stock M
Versão do Android: 6.0

  • Posts no fórum: 1.715

21/jun/2015 2:51:23 via Web

Emerson

Diego Jonathan

Emerson fiz tudo certinho, na hora de instalar outra rom dá um erro relacionado ao TWRP.

Qual erro? Instalou o TWRP modificado, né?

Na Instalação da primária ou secundaria?

Sim, instalei.
É o seguinte reinicio no modo recovery daí sigo os passos para instalar a rom secundária:

Advanced>MultiROM>AddROM, daí já tem aqui duas opções e a selecionada é Android e a outra abaixo dela é MultiROM installer (*.mrom files) daí não mecho em nada e clico em next>ZIP file> depois no zip da rom, daí o processo começa e demora um pouco e dar o seguinte erro: E: Error executing uptater binary in zip '/tmp/mr_update.zip

Em que passo estou errando, ou errei?

EDIT. Não sei que erro é esse, falei que era do TWRP mas não sei.

— alterado em 21/jun/2015 3:23:33

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

  • Posts no fórum: 1.715

21/jun/2015 5:23:32 via Web

Acho que o erro era o arquivo da rom corrompido, pois instalei outra aqui e foi normal porém não inicia, diz a seguinte mensagem:
Error
Kexec-hardboot support is required to boot this ROM
Install kernel with kexec-hardboot support to your Internal ROM

Daí instalei o attacked mas não foi.

Quebrei a cabeça que só já aqui, vou desfazer tudo e restaurar o backup que fiz.

MultiROM nunca mais!! kkkkkk

— alterado em 21/jun/2015 5:23:48

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

  • Posts no fórum: 171

21/jun/2015 13:29:13 via App

Diego Jonathan

Acho que o erro era o arquivo da rom corrompido, pois instalei outra aqui e foi normal porém não inicia, diz a seguinte mensagem:
Error
Kexec-hardboot support is required to boot this ROM
Install kernel with kexec-hardboot support to your Internal ROM

Daí instalei o attacked mas não foi.

Quebrei a cabeça que só já aqui, vou desfazer tudo e restaurar o backup que fiz.

MultiROM nunca mais!! kkkkkk

Estranho O.o . Fiz do mesmo jeito q VC citou lá em cima e deu tudo certo. Estou com a AICP e a RR com kernel Attacked.

Dispositivo: Moto G 2013 (XT1034) Codinome: Falcon
ROM: Lineage os 14.1
Kernel: Stock
Versão Android: 7.1.1
Custom Recovery: TWRP 3.1.0.0
ROOT: Nao
Xposed: Nao

Tudo o que um sonho precisa para ser realizado é alguém que acredite que ele possa ser realizado.

  • Posts no fórum: 171

21/jun/2015 13:31:30 via App

Emerson estou tendo só um probleminha aqui, o xposed nao funciona na ROM secundária. Na instalação pelo recovery da tudo certo mais quando abro o app diz q n está instalado e nao pega nenhum módulo. Já reintalei várias vezes com wipe cache/dalvik e nada. Poderia me ajudar ?
E quando for atualizar a ROM secundária como proceder ?

— alterado em 21/jun/2015 13:55:46

Dispositivo: Moto G 2013 (XT1034) Codinome: Falcon
ROM: Lineage os 14.1
Kernel: Stock
Versão Android: 7.1.1
Custom Recovery: TWRP 3.1.0.0
ROOT: Nao
Xposed: Nao

Tudo o que um sonho precisa para ser realizado é alguém que acredite que ele possa ser realizado.

  • Posts no fórum: 2.976

21/jun/2015 14:14:57 via App

Diego Jonathan

Acho que o erro era o arquivo da rom corrompido, pois instalei outra aqui e foi normal porém não inicia, diz a seguinte mensagem:
Error
Kexec-hardboot support is required to boot this ROM
Install kernel with kexec-hardboot support to your Internal ROM

Daí instalei o attacked mas não foi.

Quebrei a cabeça que só já aqui, vou desfazer tudo e restaurar o backup que fiz.

MultiROM nunca mais!! kkkkkk

Estranho, qual ROM é? Todas que testo da tudo certo, faz nesta ordem, flash do kernel com kexec hardboot, instala o twrp modificado, da flash no multiboot, e instala a ROM secundaria, se continuar dando erro. de flash do kernel com kexec hardboot na secundaria também.

Smartphone: Moto G 2014 (XT1069) - Codinome: Titan
Sistema: Marshmallow STOCK
Kernel: Stock M
Versão do Android: 6.0

  • Posts no fórum: 2.976

21/jun/2015 14:27:25 via App

Pedro

Emerson estou tendo só um probleminha aqui, o xposed nao funciona na ROM secundária. Na instalação pelo recovery da tudo certo mais quando abro o app diz q n está instalado e nao pega nenhum módulo. Já reintalei várias vezes com wipe cache/dalvik e nada. Poderia me ajudar ?
E quando for atualizar a ROM secundária como proceder ?

Como está instalando o xposed (APK, zip e processo)?

No tópico diz como atualizar.

Smartphone: Moto G 2014 (XT1069) - Codinome: Titan
Sistema: Marshmallow STOCK
Kernel: Stock M
Versão do Android: 6.0

  • Posts no fórum: 1.715

21/jun/2015 15:05:01 via App

Emerson

Diego Jonathan

Acho que o erro era o arquivo da rom corrompido, pois instalei outra aqui e foi normal porém não inicia, diz a seguinte mensagem:
Error
Kexec-hardboot support is required to boot this ROM
Install kernel with kexec-hardboot support to your Internal ROM

Daí instalei o attacked mas não foi.

Quebrei a cabeça que só já aqui, vou desfazer tudo e restaurar o backup que fiz.

MultiROM nunca mais!! kkkkkk

Estranho, qual ROM é? Todas que testo da tudo certo, faz nesta ordem, flash do kernel com kexec hardboot, instala o twrp modificado, da flash no multiboot, e instala a ROM secundaria, se continuar dando erro. de flash do kernel com kexec hardboot na secundaria também.

Já mudei a ordem, instalei o kernel via recovery dai depois o multirom e instalei a ROM secundária, depois mudei a ordem de novo mas dar aquele erro pra iniciar que falei, dai eu reiniciei no recovery e dei flash no kernel de novo mas não ia.

kexec hardboot o que é isso?
Juro que eu não tinha ouvido falar nisso ate ontem kkkk O.o

— alterado em 21/jun/2015 16:53:22

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

  • Posts no fórum: 171

21/jun/2015 17:08:04 via App

Emerson

Pedro

Emerson estou tendo só um probleminha aqui, o xposed nao funciona na ROM secundária. Na instalação pelo recovery da tudo certo mais quando abro o app diz q n está instalado e nao pega nenhum módulo. Já reintalei várias vezes com wipe cache/dalvik e nada. Poderia me ajudar ?
E quando for atualizar a ROM secundária como proceder ?

Como está instalando o xposed (APK, zip e processo)?

No tópico diz como atualizar.

Primeiramente instalo o zip via recovery e dou wipe cache/dalvik depois reboot system aí instalo o apk e diz q não está instalado e pra instalar via recovery.
Fui na pasta framework do celular e os arquivos do xposed estão lá O.o
Na ROM primária que eh a AICP ta funcionando normalmente

Vlw não tinha percebido kkk

— alterado em 21/jun/2015 17:09:45

Dispositivo: Moto G 2013 (XT1034) Codinome: Falcon
ROM: Lineage os 14.1
Kernel: Stock
Versão Android: 7.1.1
Custom Recovery: TWRP 3.1.0.0
ROOT: Nao
Xposed: Nao

Tudo o que um sonho precisa para ser realizado é alguém que acredite que ele possa ser realizado.

  • Posts no fórum: 1.715

21/jun/2015 19:20:30 via App

Emerson porque deu aquele erro👆na hora de flashear a ROM?

Tem haver com quê esse erro?
Com o arquivo zip da ROM apenas ou com o próprio TWRP??
Nunca tive esse erro aqui só comecei a ter depois de instalar o multi ROM, desinstalei e instalei o TWRP que tem aí no post mas agora estou enfrentando o mesmo erro ao tentar instalar outra ROM normalmente, porque isso?

Tenho que instalar pelo PC o TWRP novamente é, para esse problema que eu não tinha sumir?

— alterado em 21/jun/2015 19:22:13

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

  • Posts no fórum: 2.976

21/jun/2015 23:22:23 via App

Diego Jonathan

Emerson porque deu aquele erro👆na hora de flashear a ROM?

Tem haver com quê esse erro?
Com o arquivo zip da ROM apenas ou com o próprio TWRP??
Nunca tive esse erro aqui só comecei a ter depois de instalar o multi ROM, desinstalei e instalei o TWRP que tem aí no post mas agora estou enfrentando o mesmo erro ao tentar instalar outra ROM normalmente, porque isso?

Tenho que instalar pelo PC o TWRP novamente é, para esse problema que eu não tinha sumir?

Vamos lá, se ainda quiser usar o multiROM:

Instala o kernel com o patch kexec hardboot, mas desta vez use o da CM 12.1

https://basketbuild.com/filedl/devs?dev=LuK1337&dl=LuK1337/multirom-titan/boot-CM12.1.img

Instale o twrp modificado, de flash no multirom e faça o processo de instalação da ROM secundaria.

Pra desistir

De flash no unistaller e instale o twrp normal, que vai ficar como se nunca tivesse o instalado.

— alterado em 21/jun/2015 23:22:47

Smartphone: Moto G 2014 (XT1069) - Codinome: Titan
Sistema: Marshmallow STOCK
Kernel: Stock M
Versão do Android: 6.0

  • Posts no fórum: 1.715

22/jun/2015 3:30:04 via App

Emerson

Diego Jonathan

Emerson porque deu aquele erro👆na hora de flashear a ROM?

Tem haver com quê esse erro?
Com o arquivo zip da ROM apenas ou com o próprio TWRP??
Nunca tive esse erro aqui só comecei a ter depois de instalar o multi ROM, desinstalei e instalei o TWRP que tem aí no post mas agora estou enfrentando o mesmo erro ao tentar instalar outra ROM normalmente, porque isso?

Tenho que instalar pelo PC o TWRP novamente é, para esse problema que eu não tinha sumir?

Vamos lá, se ainda quiser usar o multiROM:

Instala o kernel com o patch kexec hardboot, mas desta vez use o da CM 12.1

https://basketbuild.com/filedl/devs?dev=LuK1337&dl=LuK1337/multirom-titan/boot-CM12.1.img

Instale o twrp modificado, de flash no multirom e faça o processo de instalação da ROM secundaria.

Pra desistir

De flash no unistaller e instale o twrp normal, que vai ficar como se nunca tivesse o instalado.

Ao instalar o kernel 👆 pelo aplicativo ao reiniciar entrei em bootloop infinito.

Não sei mas o que fazer para instalar isso.

EDIT. QUERO INSTALAR MAIS NÃO, VALEU EMERSON.

— alterado em 22/jun/2015 5:57:27

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

  • Posts no fórum: 2.976

22/jun/2015 20:33:23 via App

Diego Jonathan

Emerson

Diego Jonathan

Emerson porque deu aquele erro👆na hora de flashear a ROM?

Tem haver com quê esse erro?
Com o arquivo zip da ROM apenas ou com o próprio TWRP??
Nunca tive esse erro aqui só comecei a ter depois de instalar o multi ROM, desinstalei e instalei o TWRP que tem aí no post mas agora estou enfrentando o mesmo erro ao tentar instalar outra ROM normalmente, porque isso?

Tenho que instalar pelo PC o TWRP novamente é, para esse problema que eu não tinha sumir?

Vamos lá, se ainda quiser usar o multiROM:

Instala o kernel com o patch kexec hardboot, mas desta vez use o da CM 12.1

https://basketbuild.com/filedl/devs?dev=LuK1337&dl=LuK1337/multirom-titan/boot-CM12.1.img

Instale o twrp modificado, de flash no multirom e faça o processo de instalação da ROM secundaria.

Pra desistir

De flash no unistaller e instale o twrp normal, que vai ficar como se nunca tivesse o instalado.

Ao instalar o kernel 👆 pelo aplicativo ao reiniciar entrei em bootloop infinito.

Não sei mas o que fazer para instalar isso.

EDIT. QUERO INSTALAR MAIS NÃO, VALEU EMERSON.

O img do kernel pode instalar pelo TWRP também.

Mas que é estranho é, fiz este processo inúmeras vezes e sempre foi perfeito.

Mas tudo bem.

— alterado em 22/jun/2015 20:33:59

Smartphone: Moto G 2014 (XT1069) - Codinome: Titan
Sistema: Marshmallow STOCK
Kernel: Stock M
Versão do Android: 6.0

  • Posts no fórum: 1.715

22/jun/2015 20:52:09 via App

Emerson

Diego Jonathan

Emerson

Diego Jonathan

Emerson porque deu aquele erro👆na hora de flashear a ROM?

Tem haver com quê esse erro?
Com o arquivo zip da ROM apenas ou com o próprio TWRP??
Nunca tive esse erro aqui só comecei a ter depois de instalar o multi ROM, desinstalei e instalei o TWRP que tem aí no post mas agora estou enfrentando o mesmo erro ao tentar instalar outra ROM normalmente, porque isso?

Tenho que instalar pelo PC o TWRP novamente é, para esse problema que eu não tinha sumir?

Vamos lá, se ainda quiser usar o multiROM:

Instala o kernel com o patch kexec hardboot, mas desta vez use o da CM 12.1

https://basketbuild.com/filedl/devs?dev=LuK1337&dl=LuK1337/multirom-titan/boot-CM12.1.img

Instale o twrp modificado, de flash no multirom e faça o processo de instalação da ROM secundaria.

Pra desistir

De flash no unistaller e instale o twrp normal, que vai ficar como se nunca tivesse o instalado.

Ao instalar o kernel 👆 pelo aplicativo ao reiniciar entrei em bootloop infinito.

Não sei mas o que fazer para instalar isso.

EDIT. QUERO INSTALAR MAIS NÃO, VALEU EMERSON.

O img do kernel pode instalar pelo TWRP também.

Mas que é estranho é, fiz este processo inúmeras vezes e sempre foi perfeito.

Mas tudo bem.

Já desisti, Deus me livre!
Nunca mais tinha quebrado a cabeça tanto com algo relacionado a instalação de alguma coisa. Quero mas não, mas valeu!
Eu queria testar outras ROMs e deixar a minha principal intacta, mas não obtive êxito, infelizmente.

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

  • Posts no fórum: 397

22/jun/2015 21:01:34 via Web

Diego Jonathan

Emerson

Diego Jonathan

Emerson

Diego Jonathan

Emerson porque deu aquele erro👆na hora de flashear a ROM?

Tem haver com quê esse erro?
Com o arquivo zip da ROM apenas ou com o próprio TWRP??
Nunca tive esse erro aqui só comecei a ter depois de instalar o multi ROM, desinstalei e instalei o TWRP que tem aí no post mas agora estou enfrentando o mesmo erro ao tentar instalar outra ROM normalmente, porque isso?

Tenho que instalar pelo PC o TWRP novamente é, para esse problema que eu não tinha sumir?

Vamos lá, se ainda quiser usar o multiROM:

Instala o kernel com o patch kexec hardboot, mas desta vez use o da CM 12.1

https://basketbuild.com/filedl/devs?dev=LuK1337&dl=LuK1337/multirom-titan/boot-CM12.1.img

Instale o twrp modificado, de flash no multirom e faça o processo de instalação da ROM secundaria.

Pra desistir

De flash no unistaller e instale o twrp normal, que vai ficar como se nunca tivesse o instalado.

Ao instalar o kernel 👆 pelo aplicativo ao reiniciar entrei em bootloop infinito.

Não sei mas o que fazer para instalar isso.

EDIT. QUERO INSTALAR MAIS NÃO, VALEU EMERSON.

O img do kernel pode instalar pelo TWRP também.

Mas que é estranho é, fiz este processo inúmeras vezes e sempre foi perfeito.

Mas tudo bem.

Já desisti, Deus me livre!
Nunca mais tinha quebrado a cabeça tanto com algo relacionado a instalação de alguma coisa. Quero mas não, mas valeu!
Eu queria testar outras ROMs e deixar a minha principal intacta, mas não obtive êxito, infelizmente.

Cara, eu tava fora e não vi todo seu dilema, mas li agora...

Vc tem certeza q seguiu os passos q tem no video?
Mas certeza certeza mesmo?? e usou os boot.img (qdo e se necessários) corretos?

Por cima me parece q o multirom (o boot dele) não tá correto...aqui acontecia qdo eu atualizava rom (primária) via ota ou instalasse alguma coisa tipo xposed, etc...algo q pudesse mudar o boot da rom primária de alguma forma...ae eu ia lá e refazia o processo (como no video) e tudo voltava ao normal....

Device: Motorola Moto G XT1069 / TITAN
ROM: RR
Kernel: Stock
OS: M 6.0.1
Recovery: TWRP 2.8.6.0

  • Posts no fórum: 1.715

22/jun/2015 21:09:10 via App

Gean

Diego Jonathan

Emerson

Diego Jonathan

Emerson

Diego Jonathan

Emerson porque deu aquele erro👆na hora de flashear a ROM?

Tem haver com quê esse erro?
Com o arquivo zip da ROM apenas ou com o próprio TWRP??
Nunca tive esse erro aqui só comecei a ter depois de instalar o multi ROM, desinstalei e instalei o TWRP que tem aí no post mas agora estou enfrentando o mesmo erro ao tentar instalar outra ROM normalmente, porque isso?

Tenho que instalar pelo PC o TWRP novamente é, para esse problema que eu não tinha sumir?

Vamos lá, se ainda quiser usar o multiROM:

Instala o kernel com o patch kexec hardboot, mas desta vez use o da CM 12.1

https://basketbuild.com/filedl/devs?dev=LuK1337&dl=LuK1337/multirom-titan/boot-CM12.1.img

Instale o twrp modificado, de flash no multirom e faça o processo de instalação da ROM secundaria.

Pra desistir

De flash no unistaller e instale o twrp normal, que vai ficar como se nunca tivesse o instalado.

Ao instalar o kernel 👆 pelo aplicativo ao reiniciar entrei em bootloop infinito.

Não sei mas o que fazer para instalar isso.

EDIT. QUERO INSTALAR MAIS NÃO, VALEU EMERSON.

O img do kernel pode instalar pelo TWRP também.

Mas que é estranho é, fiz este processo inúmeras vezes e sempre foi perfeito.

Mas tudo bem.

Já desisti, Deus me livre!
Nunca mais tinha quebrado a cabeça tanto com algo relacionado a instalação de alguma coisa. Quero mas não, mas valeu!
Eu queria testar outras ROMs e deixar a minha principal intacta, mas não obtive êxito, infelizmente.

Cara, eu tava fora e não vi todo seu dilema, mas li agora...

Vc tem certeza q seguiu os passos q tem no video?
Mas certeza certeza mesmo?? e usou os boot.img (qdo e se necessários) corretos?

Por cima me parece q o multirom (o boot dele) não tá correto...aqui acontecia qdo eu atualizava rom (primária) via ota ou instalasse alguma coisa tipo xposed, etc...algo q pudesse mudar o boot da rom primária de alguma forma...ae eu ia lá e refazia o processo (como no video) e tudo voltava ao normal....

Que video?
Rapaz tenho certeza que segui os passos certinho... e foi mais de uma vez.

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.