Motorola Moto G (2014) — Estranho: Sinal GPS cai quando ativo 3G no chip da TIM

  • Respostas:116
  • AbertoNão stickyRespondido
  • Posts no fórum: 1

7/jul/2016 2:26:12 via Web

Realmente esse problema é uma epidemia e, pasmem, com reclamações aqui desde 2014, e nada fazem as agências. Amanhã vou testar o 2g no iPhone 4s com Tim 3G.

  • Posts no fórum: 2

12/jul/2016 21:50:59 via Web

Tente recalibrar o GPS
Calibrar a bússola
Uma das questões que pode afetar a precisão do seu GPS é uma bússola desregulada. Se for o seu caso, isso significa que o dispositivo está recebendo informações de orientação erradas, o que pode causar problemas quando se usam apps de navegação. Felizmente a solução é fácil: basta calibrar a sua bússola.

Para isso, baixe um aplicativo como o GPS Status & Toolbox, puxe o menu na lateral esquerda e depois clique em Calibrar a bússola. Depois de girar o aparelho (lentamente) duas vezes ao redor dos seus 3 eixos, clique em OK e a bússola estará calibrada.

  • Posts no fórum: 18

14/jul/2016 19:06:38 via Web

Olá Alexandre,

Acredito que não seja esse o problema, se a causa fosse a bússola descalibrada, aconteceria com outras conexões e não apenas com o 3G.

Estou com esse mesmo problema, já fiz de tudo e mesmo assim só funciona quando tiro do 3G.

Operadora: TIM RJ e Vivo RJ
Aparelho: Moto G XT1033 (2013)
ROM: Cyanogenmod 13

  • Posts no fórum: 2

14/jul/2016 19:23:35 via Web

Sim, tu tens razão. Ja penso que o problema é com as operadoras, sei lá. Daí por hora fiz o seguinte: baixei o Sygic, um GPS off line ja com os mapas, pois o Waze tava travando muito. Ainda assim tenho que usalo sem sinal de dados se não dá pau. Espero ter ajudado.

  • Posts no fórum: 1

14/jul/2016 20:16:18 via Web

   Sinceramente operadoras e fabricantes nunca ajudam o cliente, o atendimento é ótimo no ato da compra, mas quando surgem os problemas vc se depara com um bando de lixo que não procura uma solução viável para ajudar a clientela. As operadoras brasileiras, pra começar são todas um lixo, não possuem planos bons a preços acessíveis, as funcionalidades disponíveis por eles nem sempre funcionam como deveriam, a internet então é a que mais deixa a desejar.
    Apesar desses fatos, a questão do moto G, creio ser um problema mais da fabricante do que da operadora, pois na época de seu lançamento a demanda de procura pelo aparelho era enorme, devido a fabrica não conseguir suprir o grande número de encomendas, muitos aparelhos saíram para o mercado sem seus ajustes finais assim possibilitando frequentes falhas com as quais nos deparamos no cotidiano de quem o utiliza, tanto que me deparei com muitos amigos com o mesmo problema, independente da operadora ou plano utilizado.
     Mas quem se sentiu lesado pelo acontecimento, pode recorrer a justiça até 2 anos após ter adquirido o aparelho, pois o código de defesa do consumidor está aí pra isso, e não precisa de advogado particular, qualquer advogado que esteja ligado a essas leis independente de ser particular ou público consegue tomar a frente dos fatos, assim ficando nas mãos da justiça responsabilizar; fabricantes, distribuidoras, pontos de venda ou operadoras pelo transtorno sofrido pelo cliente!
  • Posts no fórum: 1

23/jul/2016 20:22:48 via Web

Solução que funcionou pra mim:

Eu estava com o mesmo problema em um moto G 1a. geração e depois com um G4, tentei várias coisas que tinha visto aqui e em outros lugares e só essa dica de trocar para 2G funcionava, mas era muito inconveniente ficar alternando toda hora. Mas depois que eu troquei o chip antigo que eu tinha por um chip novo, com suporte a 4G, o problema sumiu. Não sei se isso vai funcionar com aparelhos sem suporte a 4G, mas acho que vale a pena tentar.

  • Posts no fórum: 18

25/jul/2016 2:50:56 via Web

Galera, acabo de resolver o meu problema.

Vi em outro tópico aqui no ANDROIDPIT:
http://www.androidpit.com.br/forum/650921/motorola-moto-x-2014-problemas-no-gps-do-moto-x-xt-1097#2865314

Vou apenas copiar e colar aqui a dica do nosso amigo Alexandro Simioni e no final darei algumas dicas.

Para muitos dispositivos da Motorola (e algumas outras marcas) o GPS não funciona quando conectado a uma rede 3G. Não tem problema quando conectado a 2g, 4g, WiFi, dados desativados ou sem rede. A razão é que o Google oferece o Android com um arquivo gps.conf inválido, para dispositivos com Android puro ou quase puro (como é o caso da Motorola). Para este caso siga os passos abaixo:
É necessário substituir /system/etc/gps.conf por uma configuração válida. Pesquisar no Google por "Google gps.conf" (sem aspas). Você vai precisar de root. Não pude colocar o arquivo inteiro aqui no post porque tem links e não é permitido.
Você também precisa verificar as configurações de APN, e adicionar agps e supl se não existir.
Para um melhor desempenho alterar os servidores NTP para os mais próximos (Brasil e América do Sul em nosso caso), pesquise no Google por NTP Server List.


Dicas:
1º Baixe no google o arquivo gps.conf e coloque no lugar citado.

2º Faça as adições na configuração APN.

3º Instale o app Terminal Emulator for Android, abra o app e digite e de enter:
"# ntpdate br.pool.ntp.org br.pool.ntp.org br.pool.ntp.org" <---- Sem aspas.

Pronto, fiz apenas isso e normalizou, lembrando que sem root não rola.

  • Posts no fórum: 54

1/ago/2016 6:03:23 via Web

Cara, fiz a alteração do gps.conf, adicionei as apns e fiz o ultimo processo e continua na mesma merda.

Mas fiquei um pouco confuso no APN e no NTP ali. Vc poderia me explicar melhor como fez?

No APN é pra ir nas conf de rede da operadora e adicionar aquelas opções no tipo de apn?

E o NTP no programa que vc citou, ele tem que ficar aberto durante o uso do gps? ou depois de adicionar pode fechar o programa?

Enfim, fiz de todos os jeitos aqui e continua caindo o sinal

=/

— alterado em 1/ago/2016 7:03:02

  • Posts no fórum: 54

1/ago/2016 7:02:19 via Web

Quanto ao gps.conf achei varias versoes tbm, não sei se peguei a certa.

— alterado em 1/ago/2016 7:03:43

  • Posts no fórum: 18

1/ago/2016 19:10:14 via Web

Thiago Bach

Cara, fiz a alteração do gps.conf, adicionei as apns e fiz o ultimo processo e continua na mesma merda.

Mas fiquei um pouco confuso no APN e no NTP ali. Vc poderia me explicar melhor como fez?

No APN é pra ir nas conf de rede da operadora e adicionar aquelas opções no tipo de apn?

E o NTP no programa que vc citou, ele tem que ficar aberto durante o uso do gps? ou depois de adicionar pode fechar o programa?

Enfim, fiz de todos os jeitos aqui e continua caindo o sinal

=/

Então, funcionou só por uns dias. Deu problema novamente.

  • Posts no fórum: 54

2/ago/2016 23:21:57 via Web

Bah, que saco isso. Pior que n tem o que fazer. Trocar de chip não adianta, trocar de aparelho não adianta.

Lamentável

  • Posts no fórum: 3

3/ago/2016 20:47:38 via Web

Testei todos os procedimentos do topico, mudei a rom (stock e resurrection remix) e a operadora (tim e nextel). Nada.

— alterado em 3/ago/2016 20:48:17

  • Posts no fórum: 1

5/ago/2016 14:25:27 via Web

OI AMIGO, COMPRE UM NEXUS 5X EM 2016 E ASSIM QUE PEGUEI VI ESSE PROBLEMA, O GPS SE PERDE COM FREQUENCIA.
SE ATIVO O MODO AVIAO ELE FUNCIONA NORMALMENTE.
O PROBLEMA É QUE NAO DA PARA JOGAR POKEMON GO, USO O MESMO CHIP DA TIM EM UM S4 MINI E FUNICIA.
ACHO QUE É ALGO DO ANDROID PURO PRESENTE NOS MOTO E NEXUS

  • Posts no fórum: 7

5/ago/2016 17:43:03 via Web

Então Herbert, estou com esse problema, agora com o pokemon go resolvi correr atras, e fazendo alguns teste vi que era o 3g ligando que fazia o sinal ficar sendo perdido a cada passo.
Acho que e problema não e da Tim, tenho o aparelho e o mesmo numero da Tim a quase dois anos, quando tinha a versão 5 do android não tinha esses problemas, começou a dar problemas com a 6.
Estou fazendo alguns testes e se encontrar alguma solução post aqui, talvez o jeito seja pegar algum mod para testar.

  • Posts no fórum: 3

5/ago/2016 19:27:28 via Web

Meu Pokemon go tb não roda com 3G ligado, o GPS é bem ruim. Comprei um chip 4G e vou testar para ver se resolve.

  • Posts no fórum: 3

5/ago/2016 19:28:52 via Web

No 2G ele roda perfeito o GPS, porem numero de Pokemons que aparecem é menor pois a internet é mais lenta eu creio.