Motorola Moto G (2014) — Estranho: Sinal GPS cai quando ativo 3G no chip da TIM

  • Respostas:116
  • AbertoNão stickyRespondido
  • Posts no fórum: 7

29/ago/2016 20:14:59 via Web

Boa Tarde a todos,

Vim deixar o meu relato de como anda as coisas depois do root e as modificações do gps.conf.

Quando eu fiz o root e modifiquei o gps.config eu usei sugestão de um usuário:

NTP_SERVER=it.pool.ntp.org
NTP_SERVER=0.it.pool.ntp.org
NTP_SERVER=1.it.pool.ntp.org
NTP_SERVER=2.it.pool.ntp.org
NTP_SERVER=3.it.pool.ntp.org
NTP_SERVER=0.europe.pool.ntp.org
NTP_SERVER=1.europe.pool.ntp.org
NTP_SERVER=2.europe.pool.ntp.org
NTP_SERVER=3.europe.pool.ntp.org

XTRA_SERVER_1=<nao permitiu postar o endereco>
XTRA_SERVER_2=<nao permitiu postar o endereco>
XTRA_SERVER_3=<nao permitiu postar o endereco>

# AGPS Daemon Call
DEFAULT_AGPS_ENABLE=TRUE
DEFAULT_USER_PLANE=TRUE
DEFAULT_SSL_ENABLE=FALSE

DEBUG_LEVEL = 0
INTERMEDIATE_POS=1
ACCURACY_THRES=0

AssistMethodType=1
AgpsUse=1
AgpsServerType=1
AgpsServerIp=-1062731741
# -1062731741 is the long ip of 192.168.0.35
AgpsMtConf=0
AgpsMtResponseType=1
QOS_ACCURACY=50
QOS_TIME_OUT_AGPS=255
QosHorizontalThreshold=1000
QosVerticalThreshold=500

#Active GOOGLE
### AGPS server settings GOOGLE ###
SUPL_HOST=supl.google.com
SUPL_PORT=7276
SUPL_SECURE_PORT=7278
SUPL_NO_SECURE_PORT=3425
############################

#WiFi Position 1=”On”, 0=”Off”
ENABLE_WIPER=1

CURRENT_CARRIER=common
REPORT_POSITION_USE_SUPL_REFLOC=1

Eu mudei os IT para BR, servidores do brasil. E com essa configuração funcionou bem algum dias, ate que percebi de volta a instabilidade(bem menor que antes, mas um tanto incomodo), devido a isso corri atras e vi a sugestão de usar o app Gps Locked, não precisa de root e um APP que só forca o GPS ficar sempre ligado, ele demora a travar o GPS mas quando trava não cai mais. Por louco tentei usar o app TopNTP(precisa de root, ele nao e nada mais varias configuracoes pre definidas do gps.config) para ver se melhoria o tempo de dar lock no GPS, mas as configurações dele, não deu muito certo, demorava mais ainda para dar lock e caia de tempos em tempos, tentei junto dessas configurações mudar o valor da variável CAPABILITIES=0x37 para 0x31(nas configurações do TopNTP ela não vem, tem que colocar na mão), sem sucesso. Fiquei usando as configurações iniciais com o Gps Locked, funcionava bem.
Mas sou chato, quis que ficasse 100% fui la e troquei o simcard meu, que era da época do 3g nem tinha suporte ao 4g ainda, nunca tinha trocado devido a usar com tanta frequência a internet movel, apos a troca dele, vi que o sinal passou para 4g com ótima velocidade, mas meu GPS enlouqueceu, pegava sinal e perdia, dava umas posições nada have, o erro de precisão dele era sempre maior que 1km, resolvei usar as configurações padrões do TopNTP, peguei Brasil Genérico, depois de mudar isso, o GPS passou a travar o sinal quase instantâneo(com o gps locked ligado), estou usando por horas e horas, e nunca mais tive problemas do GPS ficar perdendo sinal, quando perde e instantâneo a recuperação do sinal.

Meu aparelho e o Nexus 5 com android 6.0.1

Quem tiver duvida ou ajuda do que eu fiz me avisa que tentarei ajudar no que puder.

  • Posts no fórum: 1

30/ago/2016 19:36:28 via Web

O problema não é da Tim. Usava esse mesmo chip da Tim em um Sony z3 de mesma versão do Android e não tinha problema para funcionar o gps com o 3 g ligado. O problema é da Motorola . É um absurdo isso . Eles tem q resolver isso urgente .

  • Posts no fórum: 7

30/ago/2016 22:18:20 via Web

Rodrigo,
Então e um problema do Android e não da Motorola, afeta dezenas de equipamentos, em um chamado aberto aqui: code.google.com/p/android/issues/detail?id=81140&cnum=500&cstart=693 tem um usuário que identificou aonde possivelmente esta dando problemas, mas acho que nao e so isso, deve ter algum problema que vem desde a versão lollipop ao usar o AGPS.
Enfim especulação a minha, como disse nos post acima o meu problema com o gps e 3g acabou depois de modificar o gps.config.

  • Posts no fórum: 3

31/ago/2016 3:02:07 via Web

Eu tinha um Moto G (primeira geração) e este ano começou a apresentar este problema.
Troquei de aparelho por um Moto G4, o problema persiste... operadora é a TIM.

Portando, troquei de aparelho, Android é outro, o que continua igual é a operadora, estou usando o mesmo sim card. Li o tópico e tem colegas falando que o problema é da TIM, outros dizem que o Android, outros a Motorola.
Desconfio que seja problema na TIM... vou tentar trocar de chip e fazer uns testes.

  • Posts no fórum: 7

1/set/2016 1:38:21 via Web

Gabriel Izumi,

O problema e no Android, mas especificamente quando as operadoras do brasil lançaram o 4g, parece que existe um problema no AGPS, estou especulando, o meu celular e um Nexus e tenho esse problema, minha irma tem adiquiriu recentemente um galaxy j5 e ela começou a sentir o problema com o gps dela ja, vou ver o que da para fazer sem fazer root.
Ja o problema nao e so da Tim a Vivo tem o mesmo problema, tem ate uma materia que saiu aqui:
www.tecmundo.com.br/vivo/102386-sinal-vivo-interferindo-gps-celulares-afirmam-usuarios.htm

Enfim, resumo da encrenca, não temos como saber o que pode ser, vamos analisando caso a casa e tentando resolver.

  • Posts no fórum: 1

2/set/2016 4:06:48 via Web

Galera, tenho um moto G 2013 com chip da TIM RS 51 e estava com o mesmo problema há muito tempo, o que resolveu no meu caso foi utilizar o app TopNTP, conforme o Dalmir Ribas sugeriu no outro post, valeu cara!

Precisa de ROOT mas foi o que solucionou o problema.

Agora meu gps está ok independente da rede móvel utilizada.

  • Posts no fórum: 7

2/set/2016 18:16:35 via Web

Estava aqui pensando em todas as possíveis soluções encontradas por mim, caso alguém tenha alguma sugestão me avisa que vou adicionando, tente uma delas na ordem, se der certo avisem(a ordem que coloquei e da menor dificuldade para a maior):

SEM ROOT

  1. Atualizar o SimCard caso seja antigo;

  2. Adicionar o paramentro 'agps' em Tipos de APN(Explicação de como mudar tem neste mesmo tópico);

  3. Usar o app GPS Locker(ele não modifica nada das configurações do android e só um app que trava o GPS e não desliga mais e força sempre a atualização do agps, bom usar ele em todos os casos o gps demora a travar);

  4. Travar a rede em 4G, para use o comando *##4636##*e marcar o tipo de rede preferida como 'LTE Only'(nao sei se aplica a todos as versões de Android);

  5. Caso não queria fazer root, marcar para usar 2G somente.

  6. Solução HARD, trocar de operadora para ver se o problema continua, testar com o simcard de outras pessoas, ouvi falar que a VIVO andou mexendo nisso, nunca ouvi falar de problemas com a OI, enfim, outra solução para quem não quer quiser fazer root.

COM ROOT

  1. Acessar o arquivo gps.conf (qualquer editor) e modificar a o valor do paramentro "CAPABILITIES" na seguintes possibilidades(Essa dica tirei daqui code.google.com/p/android/issues/detail?id=81140&cnum=500&cstart=693):
    Se for 0x37 ou 0x35 ou 0x33, altere o valor de 0x31
    Se for 0x36, altere o valor de 0x30
    Se for 0x27 ou 0x25 ou 0x23, altere o valor de 0x21
    Se for 0x26, altere o valor de 0x20
    Se for 0x17 ou 0x15 ou 0x13, altere o valor de 0x11
    Se for 0x16, altere o valor de 0x10`

  2. Instalar o TopNTP e usar a configuração 'America do Sul > Brasil', ou algum outra que condiz com seu aparelho ou região;

  3. Usar o app GPS Locker em conjunto com o as modificações do gps.config e TopNTP;

  4. Após usar o TopNTP com a configuração pre-definida, editar manualmente o o gps.config e adicionar a linha "CAPABILITIES", para esse caso e bom acessar o gps.config antes de usar o TopNTP e fazer uma copia do mesmo para saber qual o valor padrão desta;

  5. Tentar uma configuração personalizada, se procurar por gps.config tem varias possíveis combinações, nesse caso e bom entender o que esta sendo feito para não dar problemas, vou deixar uma configuração mais básica e que vi que funcionou para muita gente(incluam o h t t p:// nas linhas XTRA_ não e permitido passar o link inteiro aqui):

    SUPL_HOST=supl.google.com
    SUPL_PORT=7276
    SUPL_NO_SECURE_PORT=3425
    SUPL_SECURE_PORT=7278
    NTP_SERVER=br.pool.ntp.org
    NTP_SERVER=south-america.pool.ntp.org
    XTRA_SERVER_1=xtra1.gpsonextra.net/xtra.bin
    XTRA_SERVER_2=xtra2.gpsonextra.net/xtra.bin
    XTRA_SERVER_3=xtra3.gpsonextra.net/xtra.bin
    ENABLE_WIPER=0
    INTERMEDIATE_POS=1
    ACCURACY_THRES=5000

  6. Tem casos que o problema volta depois de alguns dias, apos mudar o o gps.config, nesses casos pode se usar o GPS Locker ou Status Gps para atualizar o AGPS, isso e especulação minha, não sei se ira resolver, pois levando pela logica que funcionou por alguns dias, pode ser algum dado que precise limpar e atualizar.

Pode ser que o problema tenha também sido corrido no Android Nougat, então caso alguém já esteja usando o mesmo, avisa se corrigiu o problema do GPS.
Quem usou alguma desses casos para tentar arrumar o gps e ou algo diferente e funcionou avisa.

  • Posts no fórum: 3

3/set/2016 23:37:44 via Web

Dalmir, obrigado pelas respostas.
Estou usando sim Card 3g ainda, não tive tempo de trocar ainda kkk. Mas farei isso é vamos ver se resolve.
Setando a rede em 2G o gps funciona normalmente. Porém essa solução não é interessante.

Quando trocar o sim Card posto aqui o resultado.

  • Posts no fórum: 14

9/set/2016 14:59:26 via Web

Fiz as modificações no APN (configurações/dados móveis/tipo apn) para default,SUPL,AGPS e com o app GPS Test usei o clear agps dps update agps e o sinal estabilizou também no 3G da Tim.
Florianópolis SC.

  • Posts no fórum: 4

15/set/2016 1:10:46 via Web

Olá,

Hoje casualmente verifiquei que no meu Moto G1 dual chip, o problema descrito se apresenta somente com o chip da TIM enquanto com o chip da Vivo o GPS funciona normalmente. Não depende do slot, pois troquei de slots os dois chips e o o problema se apresenta igualmente com a TIM.
Ainda vou ver se comprando um chip novo da TIM se o problema persiste.
Em seguida vou postar o resultado aqui.

  • Posts no fórum: 4

18/set/2016 15:53:04 via Web

Gente, agora o engraçado é que numa viagem para SC o chip da Vivo começou a apresentar o mesmo problema que até agora só se apresentava com o chip da Vivo. Eu estou chegando à conclusão que é um problema de redes.

  • Posts no fórum: 7

19/set/2016 2:00:49 via Web

Bom, dar um relato de como vão as coisas.

Meu Nexus 5 virou zumbi, o botão power dele deu curto e ficou em loop infinito reiniciando, ate ocorrer isso o problema com 3G e GPS nunca mais tinha dado problemas.

Comprei agora o Galaxy S6, peguei da TIM e logo a primeira coisa que testei foi o GPS e 3G/4G e não identifiquei problemas algum, somente uma falta de precisão em certos momentos, não testei muito ainda, estou com ele a uma semana, esse problema de precisão e a margem de erro acima de 20 metros, estou usando o Status GPS para verificar, mas o sinal pega de GPS pega sempre rápido e sem problemas, quando comprei estava sem o simcard antigo para testar, acabei pegando outro, então não tenho como comparar se usando o mesmo simcard do nexus daria problemas.

Acessei o gps.config, para verificar que configuração tem e algo bem diferente que eu tinha no nexus, sendo so 5 linhas orientalmente.
NTP_SERVER=north-america.pool.ntp.org

XTRA_SERVER_1=gllto1.glpals.com/4day/v4/latest/lto2.dat
XTRA_SERVER_2=gllto2.glpals.com/4day/v4/latest/lto2.dat

SUPL_HOST=supl.google.com
SUPL_PORT=7275

Outra coisa que pesquisei a titulo de curiosidade pode ser as frequência suportadas, já que cada operadora tem uma faixa especifica de autorizada para funcionamento, sendo que essas frequências para cada região, podendo uma operadora funcionar com XYZ no Sul e no Norte estar YXZ, por isso o problema tem se concentrado em certas regiões(www.teleco.com.br/3g_brasil_lic.asp esse site mostra quais frequências são em cada região por operadora)

Fiz uma com comparação de especificações técnicas do S6 com Nexus 5, a primeira coisa e suporte do S6 a muitas faixas da rede LTE(4G), S6 suporta 30 faixas e o Nexus 5 15, também o S6 não tem suporte a CDMA e uma variação no HSDPA(3G), o S6 não tem a faixa 800.
Isso e e só especulação, não entendo nada de telecomunicações, mas como leigo queria saber bem se essas pequenas diferenças não podem ser o motivo de funcionar ou não?

Vejo que alguns conseguiram fazer funcionar o GPS e 3G so mudando o chip, fico feliz que tenha ajudando algo, vou deixando minhas experiencias sempre que tiver novidade, talvez sempre ajude alguém.

  • Posts no fórum: 8

17/out/2016 18:48:35 via Web

moto g 1 até moto g 4 play (meu atual) conserto celulares a 14 anos.... esse problema nunca consegui solucionar de forma definitiva, moro em Curitiba, a combinação tim+motorola+3g, não ha cristo que faça funcionar... pode fazer root, alterar configurações de apn, configurações de gps... nada resolve... o único jeito é utilizar em modo GSM(2g) ou LTE(4g).
Já vi também vários relatos de outros modelos com mesmo problema, mas principalmente (região sul) é TIM + MOTOROLA.
De acordo com minhas varias leituras, acredito ser uma interferência de sinal em alguma das bandas de funcionamento 3g, mas o que não consigo entender é que funciona com a tim em outros modelos...
Um dia quem sabe seja solucionado... mas por hora é aguardar, pois existe o mesmo problema em diversas regiões do globo... mas sem uma solução 100% funcional....
Creio que não posso colocar links aqui nesta postagem, mas basta uma pesquisada na pagina da lenovo, existem vários relatos de diversos modelos similares com mesmo problema, enquanto isso fico no aguardo, casa receba alguma solução, me comprometo de informa-los... Abraço a todos e boa sorte!