Motorola Moto Maxx — [Kernel][Moto Maxx]BHB27-Kernel[5.x.x][6.0.x][CM base's]

  • Respostas:565
  • AbertoStickySem resposta
  • Posts no fórum: 65

20/jan/2016 20:09:38 via Web

Akira uma pergunta.

Quando passei da nxrom para a RR não instalei mais a xposed. Fiquei sem o greenify pro. Ainda assim sem o greenify vi melhora significativa na bateria.

Agora com os wake locks da RR, deep sleep e etc, voce ainda acha que o power nap soma algo na economia de bateria?

Pergunto mais porque estou com duvida se volto tudo com a xposed, mais por causa do minmin guard. Depois que VC falou da tela preta repensei...

  • Posts no fórum: 288

20/jan/2016 21:28:35 via Web

Paulo Alvim Borges

Akira uma pergunta.

Quando passei da nxrom para a RR não instalei mais a xposed. Fiquei sem o greenify pro. Ainda assim sem o greenify vi melhora significativa na bateria.

Agora com os wake locks da RR, deep sleep e etc, voce ainda acha que o power nap soma algo na economia de bateria?

Pergunto mais porque estou com duvida se volto tudo com a xposed, mais por causa do minmin guard. Depois que VC falou da tela preta repensei...

Aconteceu 1x a tela preta, mas não altera em nda, só reiniciar novamente e está tudo normal.

Qto ao Power Nap, eu acho sim q da uma diferença, pelo menos no meu cel com meus apps, olhando as estatisticas do Power nap ele está pegando mtos wakelocks, principalmente os do Play services q tem um monte...

Mas enfins, vai do uso.. Meu cel chega as 36, 40 hs sussa... Meu uso é mto tranquilo... Ultima versão do kernel então, tirei meu cel da tomada ontem as 23hs ja att, deixei ele ligado normal sem rede, e hj durante o dia todo ate agora no wifi e ele esta sussa aqui com 87%...

Smartphone: Moto Maxx XT1225
Codinome: Quark
ROM: Ressurection Remix 5..6.8
KERNEL: BHB27-Kernel-V129-4-M
Gapps: Open Gapps pico
Android: 6.0.1
Recovery: TWRP 3.0.2-0 Mod
SuperSU: 2.65
Xposed: Official sdk23 v83

  • Posts no fórum: 288

21/jan/2016 1:13:48 via Web

Paulo Alvim Borges

Instalei o teste 4

Dt2w excelente!

Muda a vida.

O thread do powernap esta fechado no Xda.

Tem como compartilhar conosco Akira?

Realmente faz um tempo q a thread foi fechada, no G+ falam q o projeto foi abandonado... Mas enfins esta aqui o Power Nap...

Smartphone: Moto Maxx XT1225
Codinome: Quark
ROM: Ressurection Remix 5..6.8
KERNEL: BHB27-Kernel-V129-4-M
Gapps: Open Gapps pico
Android: 6.0.1
Recovery: TWRP 3.0.2-0 Mod
SuperSU: 2.65
Xposed: Official sdk23 v83

  • Posts no fórum: 42

21/jan/2016 12:58:53 via App

A combinação perfeita que encontrei até agora, pelo menos na Mokee, em questão de bateria foi:

Governor Umbrella_Core com as frequências mínimas e máximas disponíveis.
-20 Undervolt
Hotplug Intelliplug
Intellithermal
Gpu msm adreno tz com laziness em 7 e o ramp em 2
I/O Noop com read-ahead 1024 (estou testando os read-ahead já que lendo artigos no Xda e em blogs o 3072 parece ser o mais recomendado)
Memória virtual com Overcomit em 100
Entropia em 100 pelo Seeder (Light)

Motivos:

Governor: o Zzmoove usa frequências mais baixas, porém dá engasgos algumas vezes, em fluência/bateria o Umbrella_Core é o melhor.

Hotplug: o Intelliplug é o que melhor se adapta ao Umbrella_Core.

Gpu: padrão recomendado pelo bhb

I/O: Noop em testes que fiz se adaptou melhor para essa configuração.
Read-ahead ainda em testes.

Overcomit em 100: overcomit é quanto que os apps podem usar da memória RAM. 100 = tudo.

Entropia não precisa de explicação.

Essas são as configurações que eu achei melhores pra mim.
Compartilhe suas configurações caso não sejam as recomendadas pelo bhb e vamos experimentar (:

  • Posts no fórum: 65

21/jan/2016 16:18:43 via Web

Mestre BHB

Seguinte percebi um probleminha aqui depois de instalar as coisas ontem.

Antes estava com o kernel 123 e sem xposed.

Agora instalei o kernel 124 test 4 e a xposed v79 com minmin guard, powernap, greenify e boot manager. ativei o dt2w e sweep2w no kernel

Antes de mudar estava funcionando tudo perfeitamente.

Agora o que ocorre. tinha uma pasta protegida com o cadeado com uns apps. depois da nova instalação eu tentei abrir a pasta. ele pediu o padrao de bloqueio. quando desenhei o padrao de bloqueio ele desbloqueou a tela mas a pasta continuou bloqueada e os apps não podem ser acessados.

tentei desinstalar e instalar tudo pela play para ver se saia da pasta, continuavam protegidos. apaguei a pasta, continuavam protegidos. ai fui pelo trebutchet na parte de aplicativos protegidos, desenhei o padrão, aceitou, os apps foram desbloqueados e voltaram a ser acessíveis fora da pasta (que havia sido removida).

refiz a pasta com os apps desprotegidos e tentei proteger a pasta denovo (a nova pesta vem desprotegida por default). ele não pede um padrão novo, pede para entrar um padrão, supus que fosse o antigo. quando entro o padrão antigo desbloqueia a tela mas não bloqueia a pasta! isso com qualquer pasta.

desliguei todos os modulos to xposed, coloquei o kernel teste inteiro no default, reboot, mesma coisa.

não sei se só o mainframe está dando conflito ou o novo kernel, ou se apagar algum cache dá certo...

100% contornável, mas gostava da pasta bloqueada. mais alguém tem esse problema? valeu!

  • Posts no fórum: 419

21/jan/2016 17:30:48 via Web

Paulo Alvim Borges

Mestre BHB

Seguinte percebi um probleminha aqui depois de instalar as coisas ontem.

Antes estava com o kernel 123 e sem xposed.

Agora instalei o kernel 124 test 4 e a xposed v79 com minmin guard, powernap, greenify e boot manager. ativei o dt2w e sweep2w no kernel

Antes de mudar estava funcionando tudo perfeitamente.

Agora o que ocorre. tinha uma pasta protegida com o cadeado com uns apps. depois da nova instalação eu tentei abrir a pasta. ele pediu o padrao de bloqueio. quando desenhei o padrao de bloqueio ele desbloqueou a tela mas a pasta continuou bloqueada e os apps não podem ser acessados.

tentei desinstalar e instalar tudo pela play para ver se saia da pasta, continuavam protegidos. apaguei a pasta, continuavam protegidos. ai fui pelo trebutchet na parte de aplicativos protegidos, desenhei o padrão, aceitou, os apps foram desbloqueados e voltaram a ser acessíveis fora da pasta (que havia sido removida).

refiz a pasta com os apps desprotegidos e tentei proteger a pasta denovo (a nova pesta vem desprotegida por default). ele não pede um padrão novo, pede para entrar um padrão, supus que fosse o antigo. quando entro o padrão antigo desbloqueia a tela mas não bloqueia a pasta! isso com qualquer pasta.

desliguei todos os modulos to xposed, coloquei o kernel teste inteiro no default, reboot, mesma coisa.

não sei se só o mainframe está dando conflito ou o novo kernel, ou se apagar algum cache dá certo...

100% contornável, mas gostava da pasta bloqueada. mais alguém tem esse problema? valeu!

não sei. v79 do xposed ta estranho eu não to usando testa a v78.

  • Posts no fórum: 65

21/jan/2016 21:00:58 via Web

Desinstalei o xposed com o unisntaller, permanece o mesmo. Restaurei um nandroid com kernel 123. Voltou a funcionar...

Ninguém mais com esse problema?

  • Posts no fórum: 419

21/jan/2016 21:10:37 via Web

Paulo Alvim Borges

Desinstalei o xposed com o unisntaller, permanece o mesmo. Restaurei um nandroid com kernel 123. Voltou a funcionar...

Ninguém mais com esse problema?

não tenho ideia do que tu descreve pasta com cadeado não faz sentido pra mim.

pra começar a conversa como eu faço pra reproduzir esta pasta e pq tela bloqueada desta maneira?

tudo com detalhe se não eu não tento.

— alterado em 21/jan/2016 21:11:08

  • Posts no fórum: 65

21/jan/2016 23:21:34 via Web

Seguinte, tem uma função da CM que ficou na RR que eu acho muito boa e tava funcionando até eu atualizar o kernel
Quando você junta varios apps no launcher e faz uma pasta, quando abre a pasta para acessar um app aparece isso

image

perceba que tem um cadeado embaixo, que tem a função de proteger essa pasta. quando você toca no cadeado ele pede para você entrar um padrão de bloqueio

image

assim que você coloca o padrão de bloqueio ele trava a pasta e os arquivos não ficam mais acessíveis, aparece uma pasta com um cadeado

image

para abrir os apps você clica nessa pasta com cadeado e ele abre de novo a mesma tela da imagem dois acima pedinho o padrão de desbloqueio que está cadastrado. quando a função está ok, se você desenha o padrão de desbloqueio a pasta abre como aparece na imagem 1 acima. isso pode ser feito nas duas vias, tanto para bloquear quanto para desbloquear. depois que atualizei o kernel essa função não está mais funcionando direito. o launcher não trava pastas novas e nem destrava as pastas travadas. ele pede o padrão de bloqueio, eu entro com o padrão correto mas não trava nem destrava, só volta para a página inicial do trebuchet (imagem 3).

para reproduzir é só ver se isso ocorre no seu celular, se ele ta travando e destravando a pasta ou não

  • Posts no fórum: 419

22/jan/2016 0:52:46 via Web

Paulo Alvim Borges

Seguinte, tem uma função da CM que ficou na RR que eu acho muito boa e tava funcionando até eu atualizar o kernel
Quando você junta varios apps no launcher e faz uma pasta, quando abre a pasta para acessar um app aparece isso

![image][1]

perceba que tem um cadeado embaixo, que tem a função de proteger essa pasta. quando você toca no cadeado ele pede para você entrar um padrão de bloqueio

![image][2]

assim que você coloca o padrão de bloqueio ele trava a pasta e os arquivos não ficam mais acessíveis, aparece uma pasta com um cadeado

![image][3]

para abrir os apps você clica nessa pasta com cadeado e ele abre de novo a mesma tela da imagem dois acima pedinho o padrão de desbloqueio que está cadastrado. quando a função está ok, se você desenha o padrão de desbloqueio a pasta abre como aparece na imagem 1 acima. isso pode ser feito nas duas vias, tanto para bloquear quanto para desbloquear. depois que atualizei o kernel essa função não está mais funcionando direito. o launcher não trava pastas novas e nem destrava as pastas travadas. ele pede o padrão de bloqueio, eu entro com o padrão correto mas não trava nem destrava, só volta para a página inicial do trebuchet (imagem 3).

para reproduzir é só ver se isso ocorre no seu celular, se ele ta travando e destravando a pasta ou não

[1]: https://fscl01.fonpit.de/userfiles/7053631/image/Screenshot_2016-01-21-18-54-34.jpg
[2]: https://fscl01.fonpit.de/userfiles/7053631/image/uploadedImage1453414124925.png
[3]: https://fscl01.fonpit.de/userfiles/7053631/image/Screenshot_2016-01-21-18-53-05-1453414304713.png

Um app deste não tem relação com o kernel. Eu testei esta Ok pra mim esta função eu bloqueio desbloqueio, faço uma nova pasta e executo os testes tudo normal.

limpa os dados do Trebuchet e reinicia. Qualquer problema de app tu limpa os dados do app que deu problema e reinicia, se der pra desinstalar, instalar e reiniciar, faz antes de reportar um bug do kernel. Se não resolver faz uma instalação limpa pois tu bugou algo que não tem a ver com kernel.

— alterado em 22/jan/2016 0:55:02

  • Posts no fórum: 96

22/jan/2016 3:46:23 via Web

Bhb, ontem baixei a última ROM disponibilizada, junto com o kernel 1.2.4 teste 4. Bom, até aí tudo certo, mas na hora de instalar, eu sempre vou lá no twrp e seleciono a ROM, gapps e kernel, e sempre deu certo nunca deu nada de errado. Porém, não sei se é a ROM ou o kernel, mas sempre que instalo o kernel junto com um zip que instala ou remove apps, tipo o gapps, causa bug, e não é só os gapps, todo e qual quer zip, quando flasheado ao mesmo tempo que o kernel, da esse bug e quando manda o aparelho ligar, ele fica rodando o logo da RR até aparecer aquela parte de atualizando aplicativos, e do nada reinicia, e fica nisso para sempre.
Não aconteceu só comigo, pedi para 2 pessoas que tem o maxx fazer o teste com a mesma versão do kernel e ROM e simplesmente da o mesmo erro.
Encontrei uma "solução", que não causa o bug, porém é mais incômodo e gasta mais tempo. Intalo a ROM junto com os gapps ou o kernel, e mando ligar o aparelho, liga tudo normal, porém tenho que entrar no twrp denovo para instalar o que falta, que no caso é o kernel ou o gapps. Fazendo desse jeito, o bug não acontece.
Obrigado des de já por este ótimo trabalho que você tem feito.

  • Posts no fórum: 288

22/jan/2016 11:47:36 via Web

Bom , eu sempre fiz por partes a instalação limpa... ROM + GAPPS + SuperSU 2.52, boot faço algumas config basicas, reboot recovery Bloatware remover, os 2 ae passo Xposed e e dpois kernel...

Só nos flash sujos q eu passo tudo mas tbm nessa ordem, em 2 partes sem boot...

Smartphone: Moto Maxx XT1225
Codinome: Quark
ROM: Ressurection Remix 5..6.8
KERNEL: BHB27-Kernel-V129-4-M
Gapps: Open Gapps pico
Android: 6.0.1
Recovery: TWRP 3.0.2-0 Mod
SuperSU: 2.65
Xposed: Official sdk23 v83

  • Posts no fórum: 419

22/jan/2016 14:18:16 via Web

Rafael Almeida

Bhb, ontem baixei a última ROM disponibilizada, junto com o kernel 1.2.4 teste 4. Bom, até aí tudo certo, mas na hora de instalar, eu sempre vou lá no twrp e seleciono a ROM, gapps e kernel, e sempre deu certo nunca deu nada de errado. Porém, não sei se é a ROM ou o kernel, mas sempre que instalo o kernel junto com um zip que instala ou remove apps, tipo o gapps, causa bug, e não é só os gapps, todo e qual quer zip, quando flasheado ao mesmo tempo que o kernel, da esse bug e quando manda o aparelho ligar, ele fica rodando o logo da RR até aparecer aquela parte de atualizando aplicativos, e do nada reinicia, e fica nisso para sempre.
Não aconteceu só comigo, pedi para 2 pessoas que tem o maxx fazer o teste com a mesma versão do kernel e ROM e simplesmente da o mesmo erro.
Encontrei uma "solução", que não causa o bug, porém é mais incômodo e gasta mais tempo. Intalo a ROM junto com os gapps ou o kernel, e mando ligar o aparelho, liga tudo normal, porém tenho que entrar no twrp denovo para instalar o que falta, que no caso é o kernel ou o gapps. Fazendo desse jeito, o bug não acontece.
Obrigado des de já por este ótimo trabalho que você tem feito.

Esse problema não ocorreu comigo deve ter algo no teu aparelho tu fez a instalação suja algo assim eu não sei esse teu gapps talvez não seja o recomendado.

Eu nunca faço o flash do gaps junto da ROM pois sempre faço limpa e não quero ver a tela de recepção da google me pedindo um monte de coisa, mas eu sempre faço o flash da ROM + kernel + zip que limpa a ROM + zip de uma bootaimation que uso, e aqui foi 100% sempre. Depois eu volto faço gapps xposed e titanium (v78 do xposed funciona a V79 da umas travadas neste caso).

No zip do kernel não tem diferença seja da versão 121 ate a ultima é tudo igual o que muda é o conteúdo do kernel ou seja o processo de flash é sempre o mesmo padram e não deve dar problema pois nunca deu e é o processo padram usado em centenas de aparelhos por vários desenvolvedores.

Nestas ultimas versões da ROM tem muita coisa de segurança da google por isso instalações limpas são recomendadas se tu vem fazendo suja a tempos pode ser isso.

— alterado em 22/jan/2016 14:20:14

  • Posts no fórum: 187

22/jan/2016 14:32:54 via Web

eu sempre fiz instalação suja e aparentemente sempre funcionou tudo

instalo ROM + GApps + SUser + Xposed, reboot
limpo o cache do app do kernel
depois instalo Bloatware remover + BootAnimation + Kernel
não instalei o kernel teste ainda, como sempre faço instalação suja, vou esperar mais um tempo pra me esquivar de possíveis problemas

  • Posts no fórum: 96

22/jan/2016 14:47:08 via Web

Bom, vamos começar, eu nunca fiz instalação suja. Não é os gapps, porque também testei outros. Não é apenas meu aparelho porque como disse, dois outros amigos também fizeram o teste.
Então deixa quieto, já consegui pular o problema...

  • Posts no fórum: 419

22/jan/2016 15:11:40 via Web

Rafael Almeida

Bom, vamos começar, eu nunca fiz instalação suja. Não é os gapps, porque também testei outros. Não é apenas meu aparelho porque como disse, dois outros amigos também fizeram o teste.
Então deixa quieto, já consegui pular o problema...

Um zip que tu esta usando é o problema só tem um pacote de gaps que recomendo e testo e não faço o flash dele junto da ROM faço separado pra evitar erros relacionados a gapps e é assim que recomendo.

Tu usa o gapps slim zero? pois ;e este o recomendado nenhum outro irei testar enquanto este estiver funcionando.

se tu não usa recomendo este gaps, e seguir o processo de instalação que da certo o que recomendo e xposed v78 ate que as atualizações de segurança estejam todas corrigidas.

  • Posts no fórum: 288

22/jan/2016 20:27:06 via App

Bom eu tive um problema igual o do Rafael, mas, foi fazendo um dirty flash...
Depois fiz um limpo e não tive nenhum problema. E eu uso ainda o open gapps pico...

Smartphone: Moto Maxx XT1225
Codinome: Quark
ROM: Ressurection Remix 5..6.8
KERNEL: BHB27-Kernel-V129-4-M
Gapps: Open Gapps pico
Android: 6.0.1
Recovery: TWRP 3.0.2-0 Mod
SuperSU: 2.65
Xposed: Official sdk23 v83