Motorola Moto G (2014) — XT1068 com problemas no GPS (3 vezes na assistência técnica, sem resolução)

  • Respostas:10
  • AbertoNão stickySem resposta
  • Posts no fórum: 6

21/jan/2016 14:12:39 via Web

Meu XT1068 não tem nenhuma custom ROM, a única atualização feita foi do KitKat para o Lollipop. Mas o GPS não funciona corretamente desde a atualização para o Lollipop. Atualmente, qualquer app que necessite do GPS só consegue pegar a posição inicial em que a atividade foi iniciada (inclusive o Maps) e não consegue atualizar a mesma.

Já tentei limitar a utilização de dados para 2G, mas o problema persiste. Já fiz testes com outros chips também, inclusive usar meu chip em outro smartphone e o problema só acontece no meu XT1068.

Ao levar na assistência, por 2 vezes somente atualizaram o sistema e disseram ter funcionado. Na terceira vez, disseram não terem encontrado erro algum.

Se tiverem alguma dica de como corrigir, agradeço imensamente.

  • Posts no fórum: 1.648

21/jan/2016 21:00:30 via Web

Seguinte, baixa o ADB + Fastboot, descompacta no desktop, aí tu pressiona shift e clica com o botão direito na pasta dele e clica em "Abrir janela de comando aqui", depois entra no modo fastboot no teu moto g (Pressiona Power + Volume -) e então é só digitar esses dois comandos e reiniciar o aparelho :

fastboot erase modemst1
fastboot erase modemst2

Escreva um de cada vez (cool)

Agora o GPS deve estar funcionando, se não funcionar acho que pode ser problema no Hardware.

(danger) É importante ter os Drivers da Motorola, se não tiver, instale.

Te ajudei? agradeça clicando no obrigado!

📱Smartphone: Moto G 2014 (XT1069) (TITAN)
🌍ROM: CyanogenMod 13
🔥Kernel: STOCK
🎯 Versão do Android: 6.0.1
🌟 Custom Recovery: TWRP 3.0.0.0

  • Posts no fórum: 6

22/jan/2016 13:46:01 via Web

Antony, obrigado pela resposta, mas o prompt de comando não entende fastboot como um comando válido.

Usei:

mfastboot erase modemst1
mfastboot erase modemst2

Vou fazer os testes agora.

  • Posts no fórum: 1.648

23/jan/2016 16:42:22 via Web

fastboot ou mfastboot vai depender de como tá o nome lá no seu "fastboot" se ele tem um "m" na frente tem que digitar com um "m" também, mas pelo visto não é problema no sistema e sim no Hardware, acho que a única solução é a troca do aparelho na assistência da motorola.

Te ajudei? agradeça clicando no obrigado!

📱Smartphone: Moto G 2014 (XT1069) (TITAN)
🌍ROM: CyanogenMod 13
🔥Kernel: STOCK
🎯 Versão do Android: 6.0.1
🌟 Custom Recovery: TWRP 3.0.0.0

  • Posts no fórum: 6

24/jan/2016 0:53:32 via Web

Antony

fastboot ou mfastboot vai depender de como tá o nome lá no seu "fastboot" se ele tem um "m" na frente tem que digitar com um "m" também, mas pelo visto não é problema no sistema e sim no Hardware, acho que a única solução é a troca do aparelho na assistência da motorola.

Na pasta está mfastboot, por isso usei este comando.

Natanael Caetano

já tentou usar o APP GPS Status?
Tente redefinir o A-GPS, isso pode resolver.

Já tentei usar, mas não resolveu.

Tudo indica que realmente é problema de hardware. Infelizmente, a Motorola tem se feito de desentendida, pois já tentei explicar 2 vezes que o problema é provavelmente um problema no aparelho e a empresa diz que ela não tem como aceitar que o defeito é no aparelho quando está sendo usada por aplicativos de terceiros.
Se tiverem alguma dica sobre como eu devo abordar essa situação, agradeço imensamente.

  • Posts no fórum: 6

24/jan/2016 1:08:41 via Web

Este é o vídeo do problema relatado. Notem que apesar da posição ser atualizada no Maps, existe um ponto no ponto de partida que não se move e por isso o aplicativo não entende que há movimentação. Isso pode ser visto também pois as instruções dadas pelo aplicativo não são atualizadas!

  • Posts no fórum: 6

25/jan/2016 22:28:23 via Web

Levei pela 4ª vez na assistência da Motorola e com o vídeo os convenci que o problema era no hardware. Dessa forma, efetuaram a troca da placa principal do XT1068 e agora está funcionando perfeitamente!

Obrigado a todos que responderam tentando ajudar!