Link2sd não funciona no 5.1.1?

  • Respostas:21
  • AbertoNão stickySem resposta
  • Posts no fórum: 62

4/set/2016 6:14:24 via App

Ontem fiz um tópico sobre o link2sd.
Hoje tentei fazer o tutorial de configuração.
Começou com o problema na segunda partição, tive de mudar de Ext2 para Ext4, e tipo, o app pede para reiniciar o smartphone, ele reinicia mas não reconhece a segunda partição no boot de inicialização.
Alguém tem solução pra esse problema?

— alterado em 4/set/2016 6:15:46

  • Posts no fórum: 62

5/set/2016 1:10:49 via App

André V.

Você possui root no celular? Esse app necessita do mesmo para funcionar.

Sim. Kkk
Eu sei como funciona.
Pra atualizar o post, eu fui no fórum do xda-developers, e pelo o que eu vi, o app funciona, mas é necessário fazer uma reinicialização rápida toda vez que for religar o smartphone.

  • Posts no fórum: 68

5/set/2016 5:19:42 via Web

tem que ser ext4 e se não montar a partição no boot me parece q vc não tem suporte init.d pra poder executar o script de montagem no boot, veja se vc tem a pasta /system/etc/init.d

  • Posts no fórum: 62

5/set/2016 5:26:53 via App

Lucas Cerqueira

tem que ser ext4 e se não montar a partição no boot me parece q vc não tem suporte init.d pra poder executar o script de montagem no boot, veja se vc tem a pasta /system/etc/init.d

Olhei e não tenho não parceiro

  • Posts no fórum: 68

5/set/2016 19:32:19 via Web

tem alguns apps q fazem isso mas se vc usa o SuperSU tem q ser manualmente senão o app exclui alguns arquivos do SuperSU e vc perde o root...

  • Posts no fórum: 62

5/set/2016 19:34:14 via App

Lucas Cerqueira

tem alguns apps q fazem isso mas se vc usa o SuperSU tem q ser manualmente senão o app exclui alguns arquivos do SuperSU e vc perde o root...

Ah sim. Precisa de mais algum arquivo adicional, ou só criar a pasta?

  • Posts no fórum: 68

5/set/2016 22:26:48 via Web

pra criar o suporte init.d precisa desses arquivos aqui:
https://drive.google.com/file/d/0B1oisRfSpnbVUHJzMEEwWkRlS0E/view?usp=sharing

baixa e extrai
com algum explorador root mova o arquivo install-recovery-2.sh pra pasta /system/etc e dê as permissões rwx-rx-rx ou 755 e nessa mesma crie a pasta init.d ficando /system/etc/init.d e dê permissões 755 tbm
depois mova o arquivo sysinit pra pasta /system/bin e dê permissões 755 tbm com isso é só reiniciar e testar o Link2SD de novo, as permissões tem q tá certa senão ñ funciona

  • Posts no fórum: 62

5/set/2016 22:28:31 via App

Lucas Cerqueira

pra criar o suporte init.d precisa desses arquivos aqui:
https://drive.google.com/file/d/0B1oisRfSpnbVUHJzMEEwWkRlS0E/view?usp=sharing

baixa e extrai
com algum explorador root mova o arquivo install-recovery-2.sh pra pasta /system/etc e dê as permissões rwx-rx-rx ou 755 e nessa mesma crie a pasta init.d ficando /system/etc/init.d e dê permissões 755 tbm
depois mova o arquivo sysinit pra pasta /system/bin e dê permissões 755 tbm com isso é só reiniciar e testar o Link2SD de novo, as permissões tem q tá certa senão ñ funciona

Blz mano. Vou já testar.

  • Posts no fórum: 62

6/set/2016 6:27:06 via App

Lucas Cerqueira

pra criar o suporte init.d precisa desses arquivos aqui:
https://drive.google.com/file/d/0B1oisRfSpnbVUHJzMEEwWkRlS0E/view?usp=sharing

baixa e extrai
com algum explorador root mova o arquivo install-recovery-2.sh pra pasta /system/etc e dê as permissões rwx-rx-rx ou 755 e nessa mesma crie a pasta init.d ficando /system/etc/init.d e dê permissões 755 tbm
depois mova o arquivo sysinit pra pasta /system/bin e dê permissões 755 tbm com isso é só reiniciar e testar o Link2SD de novo, as permissões tem q tá certa senão ñ funciona

Continuou com o mesmo erro parceiro. As permissões ficaram em rwx-r-x-r-x

  • Posts no fórum: 62

6/set/2016 21:24:03 via App

Lucas Cerqueira

recriou os scripts de montagem com link2sd?

Sim sim, e reiniciei quando reconheceu o script de montagem.
Reiniciei e o erro persistiu.

  • Posts no fórum: 62

6/set/2016 22:35:58 via App

Lucas Cerqueira

se der p mandar um print dos arquivos q falei fica melhr p ver se tem algum erro

Parceiro, talvez o único erro foi que coloquei a Init.d com esse i maiúsculo, mas já corrigi isso.
Tirei os prints, mas não posso enviar agora. Mais tarde envio e você dá uma olhada.
Tentei novamente com o i minúsculo e não deu certo.

  • Posts no fórum: 68

6/set/2016 23:05:29 via Web

sim sim man, outra coisa, veja se vc tem os arquivos recovery-installer.sh e o recovery-installer-2.sh na pasta /system/etc

  • Posts no fórum: 62

6/set/2016 23:10:47 via App

Lucas Cerqueira

sim sim man, outra coisa, veja se vc tem os arquivos recovery-installer.sh e o recovery-installer-2.sh na pasta /system/etc

tenho só o recovery-installer-2.sh que veio no zip

  • Posts no fórum: 62

6/set/2016 23:12:33 via App

Leo Rockstar

Lucas Cerqueira

sim sim man, outra coisa, veja se vc tem os arquivos recovery-installer.sh e o recovery-installer-2.sh na pasta /system/etc

tenho só o recovery-installer-2.sh que veio no zip

na verdade é install-recovery-2.sh

  • Posts no fórum: 68

6/set/2016 23:36:21 via Web

estranho, pq é o superSU que cria o install-recovery.sh...

se vc botou todos os arquivos no lugar certo então são as permissões msm, se vc tiver algum terminal dá esses comandos nele:

su
chmod 755 /system/etc/install-recovery-2.sh
chmod 755 /system/etc/init.d
chmod 755 /system/bin/sysinit
chmod 755 /system/etc/init.d/11link2sd
exit

daí reinicia e vê se funfou

  • Posts no fórum: 1

25/mar/2017 16:27:01 via Web

Estou com o mesmo problema com o link2sd no android 5.1.1. Fiz todo o processo como está descrito, com as permissões exatamente iguais e não deu certo. Continua o mesmo erro de montagem no boot e tenho que fazer a reinicialização rápida.