Motorola Moto G — [TUTORIAL][CM12/5.0.2]Resolver bug do microfone no WhatsApp

  • Respostas:26
  • AbertoNão stickySem resposta
  • Posts no fórum: 24

03/04/2015, 19:50:45 via App

Não sei se alguém já postou aqui, mas tava pesquisando por aí e achei a solução do bug das ligações no WhatsApp, com o microfone mudo.

Vá na pasta /system e abra o arquivo build.prop

Procure a linha "use.voice.path.for.pcm.voip=true"

Mude para "use.voice.path.for.pcm.voip=false" depois salva e reinicia o celular. No meu celular funcionou.

— alterado em 03/04/2015, 19:52:41

Tony MontanaRicardo AlvesAlex DuarteJCBotelho

Responder
  • Posts no fórum: 1 715

05/06/2015, 06:14:47 via App

Aldo Dos Anjos

Não sei se alguém já postou aqui, mas tava pesquisando por aí e achei a solução do bug das ligações no WhatsApp, com o microfone mudo.

Vá na pasta /system e abra o arquivo build.prop

Procure a linha "use.voice.path.for.pcm.voip=true"

Mude para "use.voice.path.for.pcm.voip=false" depois salva e reinicia o celular. No meu celular funcionou.

Muito obrigado colega por compartilhar esta dica com a gente, estava com o mesmo problema aqui e consegui resolver seguindo sua dica, valeu!!

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

Responder
  • Posts no fórum: 64

11/06/2015, 23:29:14 via Web

Aldo Dos Anjos

Não sei se alguém já postou aqui, mas tava pesquisando por aí e achei a solução do bug das ligações no WhatsApp, com o microfone mudo.

Vá na pasta /system e abra o arquivo build.prop

Procure a linha "use.voice.path.for.pcm.voip=true"

Mude para "use.voice.path.for.pcm.voip=false" depois salva e reinicia o celular. No meu celular funcionou.

Perfeito, cara!

Tô usando a ROM Resurrection Remix, que é baseada na CM12, e acabei de perceber esse bug.

Graças a você (e ao Google, que me trouxe aqui), consegui resolver em menos de 15 minutos após de descobrir o problema.

Valeu!

Responder
  • Posts no fórum: 1 715

14/06/2015, 15:33:20 via App

Tutorial em vídeo:
https://www.youtube.com/playlist?list=PLaP1h8v6D26CeZqMsaTp8-fgWtYO5ICQt

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

rogerio soares

Responder
  • Posts no fórum: 1 715

15/06/2015, 15:27:06 via App

rogerio soares

Olá! Só que o meu microfone não está mudo. Apenas o modo alto-falante não funciona.

OK então, talvez funcione, mas não sei com certeza, pois o problema q tive aqui foi que ficava mudo (picotando) tanto no alto falando como normal, e só era nas ligações do whatsapp tbm.

— alterado em 15/06/2015, 15:27:59

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

Responder
  • Posts no fórum: 270

15/06/2015, 15:51:27 via App

Recomendo vocês atualizarem as suas ROMs, porque a minha atual CyanoGenMod 12 5.1.1 está tudo funcionando de boa e esse bug do microfone já foi corrigido há tempos.

Responder
  • Posts no fórum: 1 715

15/06/2015, 15:55:58 via App

Matheus

Recomendo vocês atualizarem as suas ROMs, porque a minha atual CyanoGenMod 12 5.1.1 está tudo funcionando de boa e esse bug do microfone já foi corrigido há tempos.

Estou usando a RR última versão lançada pra moto g 2014, que é baseada na CM 12.1, com Android 5.1.1 instalei e esse bug persistia eu só resolvi fazendo o que o amigo lá em cima postou daí fiz um vídeo tutorial ensinando como fazer.

— alterado em 15/06/2015, 15:57:06

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

Responder
  • Posts no fórum: 2

17/06/2015, 16:59:36 via Web

Oi galera , estou com o mesmo problema, meu microfone nas ligacoes do telefone não funciona o audio eu consigo ouvir direito mais o microfone não, nas chamadas do whatsapp tb não consigo escutar, ja testei gravar voz no whatsapp e funcionou tranquilo. testei esse tutorial ai que vcs passaram só que não achei essa linha ai no meu. o que pode ser?

Responder
  • Posts no fórum: 1 715

18/06/2015, 10:58:11 via Web

Yuri Dantas

Oi galera , estou com o mesmo problema, meu microfone nas ligacoes do telefone não funciona o audio eu consigo ouvir direito mais o microfone não, nas chamadas do whatsapp tb não consigo escutar, ja testei gravar voz no whatsapp e funcionou tranquilo. testei esse tutorial ai que vcs passaram só que não achei essa linha ai no meu. o que pode ser?

Qual rom e aparelho você usa?

EDIT.: PROCURE COM ATENÇÃO, SEGUINDO OS PASSOS ACIMA.

— alterado em 18/06/2015, 12:20:46

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

Responder
  • Posts no fórum: 1 103

18/06/2015, 11:26:35 via App

Yuri Dantas

Oi galera , estou com o mesmo problema, meu microfone nas ligacoes do telefone não funciona o audio eu consigo ouvir direito mais o microfone não, nas chamadas do whatsapp tb não consigo escutar, ja testei gravar voz no whatsapp e funcionou tranquilo. testei esse tutorial ai que vcs passaram só que não achei essa linha ai no meu. o que pode ser?

Procura direito que essa linha existe em toda build.prop

Responder
  • Posts no fórum: 24

18/06/2015, 17:03:17 via App

Yuri Dantas

Oi galera , estou com o mesmo problema, meu microfone nas ligacoes do telefone não funciona o audio eu consigo ouvir direito mais o microfone não, nas chamadas do whatsapp tb não consigo escutar, ja testei gravar voz no whatsapp e funcionou tranquilo. testei esse tutorial ai que vcs passaram só que não achei essa linha ai no meu. o que pode ser?

Eu também não estava achando cara, mas da uma olhada com calma que tem essa linha, em todos tem. Ou então baixa o Kernel Adiutor, ele tem a opção build.prop, basta vc ir na pesquisa e digitar o nome da linha.

E a questão que o bug do whats foi corrigido, porém alguns app de chamadas por IP apresenta este problema, um exemplo é o mesenger.

— alterado em 18/06/2015, 17:05:48

Responder
  • Posts no fórum: 1 103

28/06/2015, 15:50:19 via App

SalyFrancis Araújo

Galera helppppp eu não consigo alterar pra FALSE, diz que não tenho permissões, estou com a CM 12.1 e com root.

Mas tem que liberar a permissão para o aplicativo que tu tá usando pra alterar o build.prop

Responder
  • Posts no fórum: 82

28/06/2015, 15:51:23 via Web

ronaldo ramos

SalyFrancis Araújo

Galera helppppp eu não consigo alterar pra FALSE, diz que não tenho permissões, estou com a CM 12.1 e com root.

Mas tem que liberar a permissão para o aplicativo que tu tá usando pra alterar o build.prop

e como libero isso? já furcei tudo aqui...

Responder
  • Posts no fórum: 1 715

28/06/2015, 17:15:32 via App

SalyFrancis Araújo

ronaldo ramos

SalyFrancis Araújo

Galera helppppp eu não consigo alterar pra FALSE, diz que não tenho permissões, estou com a CM 12.1 e com root.

Mas tem que liberar a permissão para o aplicativo que tu tá usando pra alterar o build.prop

e como libero isso? já furcei tudo aqui...

Vá em >configurar>apps, procure o >superUS, e limpe os dados, daí quando VC for alterar o buil.prop vai pedir permissão, é só você dar a permissão e alterar de boa. ;)

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

Responder
  • Posts no fórum: 82

28/06/2015, 17:18:47 via Web

Diego Jonathan

SalyFrancis Araújo

ronaldo ramos

SalyFrancis Araújo

Galera helppppp eu não consigo alterar pra FALSE, diz que não tenho permissões, estou com a CM 12.1 e com root.

Mas tem que liberar a permissão para o aplicativo que tu tá usando pra alterar o build.prop

e como libero isso? já furcei tudo aqui...

Vá em >configurar>apps, procure o >superUS, e limpe os dados, daí quando VC for alterar o buil.prop vai pedir permissão, é só você dar a permissão e alterar de boa. ;)

Conseguir por outro método, Alterei para false, Salvei..Reiniciei, E quando fui testar mesmo problema do outro lado ninguém me escuta... Já voltei pra rom stock..

Responder
  • Posts no fórum: 82

28/06/2015, 17:19:58 via Web

SalyFrancis Araújo

Diego Jonathan

SalyFrancis Araújo

ronaldo ramos

SalyFrancis Araújo

Galera helppppp eu não consigo alterar pra FALSE, diz que não tenho permissões, estou com a CM 12.1 e com root.

Mas tem que liberar a permissão para o aplicativo que tu tá usando pra alterar o build.prop

e como libero isso? já furcei tudo aqui...

Vá em >configurar>apps, procure o >superUS, e limpe os dados, daí quando VC for alterar o buil.prop vai pedir permissão, é só você dar a permissão e alterar de boa. ;)

Conseguir por outro método, Alterei para false, Salvei..Reiniciei, E quando fui testar mesmo problema do outro lado ninguém me escuta... Já voltei pra rom stock..

Ahhh detalhe, depois reiniciei de novo e não subiu mais o CM...

Responder
  • Posts no fórum: 1 715

28/06/2015, 18:44:02 via App

SalyFrancis Araújo

SalyFrancis Araújo

Diego Jonathan

SalyFrancis Araújo

ronaldo ramos

SalyFrancis Araújo

Galera helppppp eu não consigo alterar pra FALSE, diz que não tenho permissões, estou com a CM 12.1 e com root.

Mas tem que liberar a permissão para o aplicativo que tu tá usando pra alterar o build.prop

e como libero isso? já furcei tudo aqui...

Vá em >configurar>apps, procure o >superUS, e limpe os dados, daí quando VC for alterar o buil.prop vai pedir permissão, é só você dar a permissão e alterar de boa. ;)

Conseguir por outro método, Alterei para false, Salvei..Reiniciei, E quando fui testar mesmo problema do outro lado ninguém me escuta... Já voltei pra rom stock..

Ahhh detalhe, depois reiniciei de novo e não subiu mais o CM...

Estranho cara, era para iniciar normal, tem certeza que mudou a linha certa?

Meu Canal no YouTube: JonathanDroid
Meu Blog: Blog JonathanDroid
Smartphone: Moto G 2014 (XT1069) DTV 16GB

Se meu tópico ou post te ajudou de alguma maneira, deixe seu “Obrigado” (curtir) em forma de agradecimento.

Responder

Artigos recomendados