ASUS Zenfone 2 — Backup do IMEI e LineageOS 14.1 Oficial!

  • Respostas:12
  • AbertoNão stickySem resposta
  • Posts no fórum: 12

16/03/2017, 14:28:41 via Web

Pessoal, preciso de algumas infos sobre estes dois assuntos. Tenho um Zenfone 2 ZE551ML de 16GB, com android MM, mas pretendo trocar pelo 7.x, pois essa versão MM da asus é uma droga.

Percebi que com o passar do tempo o smart piora cada vez mais. Mas antes de trocar de so, quero fazer o backup do IMEI, no caso de acontecer algum problema futuro.

Qual o método ideal de backup desses dados? Essa dica aqui funciona para o ZE551ML - http://www.androidpit.com.br/forum/638120/dica-backup-do-imei-efs-pelo-recovery-twrp ???

Agradeço qualquer dica sobre o assunto pessoal!

A outra dúvida é sobre o LineageOS 14.1, alguém aqui já o tem instalado no ZE2? Se sim, como está a performance, bugs e afins?

Está funcionando numa boa? Quero instalar a versão oficial mesmo, pois não confio muito nas versões não oficiais.

Qual o método correto de instalação? Pelo pouco que pesquisei, falam que é pra usar a versão mais atual do TWRP, é isso mesmo?

Desde já agradeço a todos que puderem me ajudar nessas dúvidas, pois quero melhorar ainda mais meu ZE2, sinto que ele pode dar ainda mais.

Tenho quase certeza que a falta de performance também é culpa dessa ROM lixenta da asus, cheia de porcaria e pra piorar não se pode remover ou desabilitar muita coisa.

Responder
  • Posts no fórum: 332

16/03/2017, 19:13:28 via App

Não sei dizer se dispositivos Asus tem a partição EFS, pois uso Motorola e ela não tem.
Mas tem aplicativo para isso, não lembro o nome.

O recomendado é sempre estar com o TWRP atualizado.

A questão do LineageOS, creio que para seu aparelho não esteja com grandes bugs.
A equipe da LineageOS recentemente retirou o suporte para um aparelho que estava apresentando problema recorrente.
Se tiver suporte oficial, pode ter certeza que não tem bug incômodo

Por favor, se a resposta lhe foi útil contribua atribuindo um "Obrigado"

Dispositivo: Moto G
Modelo: XT1033
OS: Android 7.1.2 (AOSP Extended 4.2 )

StrikerFX

Responder
  • Posts no fórum: 12

16/03/2017, 21:59:36 via Web

Opa, obrigado pela informação. Também tenho essa dúvida, se o ZF2 tem EFS ou não.

Vi um tópico no xda de um user falando sobre o backup da EFS, pelo que ele falava, parece que o ZF2 também tem.

Acho que vou instalar o TWRP e ver se aparece opção de backup dessa pasta, caso tenha, irei guardar o backup desses arquivos, pois caso no futuro precise de suporte da asus, eles estejam disponíveis na recuperação do mesmo.

Responder
  • Posts no fórum: 332

16/03/2017, 22:20:46 via App

Eu achei um tutorial em inglês de como fazer backup do imei, só precisa de root.
Caso não tenha a opção no TWRP você pode tentar.
https://www.asus.com/zentalk/in/thread-73972-1-1.html

Por favor, se a resposta lhe foi útil contribua atribuindo um "Obrigado"

Dispositivo: Moto G
Modelo: XT1033
OS: Android 7.1.2 (AOSP Extended 4.2 )

StrikerFX

Responder
  • Posts no fórum: 12

25/03/2017, 12:31:56 via Web

Fiz o backup desses arquivos do tutorial, também fiz backup da pasta config, mmc14 e do nvram.bin, espero que isso seja suficiente.

Vou pesquisar pra ver se acho mais informações sobre onde fica realmente os dados do imei do zf2, pois pelo que percebi, é obscuro seu local de instalação.

Responder
  • Posts no fórum: 12

25/03/2017, 23:19:41 via Web

Instalei o lineage os 14.1, mas estou tendo apenas um problema no momento.

Ele reconhece sem problemas os 2 sim, uso claro e tim, mas infelizmente ele não detecta os contatos dos sim, tem como resolver isso?

Testei apenas um sim de cada vez, agora no momento, estou usando só o da claro, mas logo de cara ele manda uma msg avisando que não é possível a configuração do sim pois a configuração remota não funciona no meu aparelho.

O que é preciso ativar no lineage pra funcionar isso?

Até o momento, estou adorando essa ROM, mas esse problema está me deixando triste, não quero ter que voltar para a stock só por causa disso.

Natanael, amigo, vc sabe como resolvo esse pepino? Só lembrando que o IMEI está normal, já fui em sobre o dispositivo e está lá, também digitei o *#06#, também aparece normalmente.

Responder
  • Posts no fórum: 332

26/03/2017, 16:37:15 via App

StrikerFX

Instalei o lineage os 14.1, mas estou tendo apenas um problema no momento.

Ele reconhece sem problemas os 2 sim, uso claro e tim, mas infelizmente ele não detecta os contatos dos sim, tem como resolver isso?

Testei apenas um sim de cada vez, agora no momento, estou usando só o da claro, mas logo de cara ele manda uma msg avisando que não é possível a configuração do sim pois a configuração remota não funciona no meu aparelho.

O que é preciso ativar no lineage pra funcionar isso?

Até o momento, estou adorando essa ROM, mas esse problema está me deixando triste, não quero ter que voltar para a stock só por causa disso.

Natanael, amigo, vc sabe como resolvo esse pepino? Só lembrando que o IMEI está normal, já fui em sobre o dispositivo e está lá, também digitei o *#06#, também aparece normalmente.

Eu uso o App de contatos do Google, e também não aparece a opção de exibir os contatos do chip, mas há uma opção para importar do chip.
O que eu acho até melhor, porque é feito o backup para a conta Google e há possibilidade de acrescentar mais dados ao contato.

Essa configuração remota é para receber o ponto de acesso, e é desnecessário na LineageOS, porque ele já contém para todas operadoras

— alterado em 26/03/2017, 16:42:40

Por favor, se a resposta lhe foi útil contribua atribuindo um "Obrigado"

Dispositivo: Moto G
Modelo: XT1033
OS: Android 7.1.2 (AOSP Extended 4.2 )

StrikerFX

Responder
  • Posts no fórum: 12

27/03/2017, 01:31:33 via Web

Instalei o app do google para contatos, usei a opção de importar contatos do app, não mudou, foi a mesma coisa do app nativo, não encontra nada, tanto no SIM1 ou SIM2.

Pra ferrar, o zf2 estava instável, pensei que era por causa de algo que tinha corrompido na instalação do LOS 14.1, fui fazer wipe no recovery e bam, ao voltar para o sistema, IMEI null, fiquei louco.

De início, apenas o SIM1 ficou com imei null, mas foi só desligar e religar o smart e o SIM2 foi pro buraco também.

Não satisfeito, pra zoar, o SO perde o sn, mac de rede e BT e mais algumas coisas referentes ao imei e rede, praticamente inutilizou o smart.

Sorte que eu tinha feito backup daqueles arquivos descritos no post anterior, do link que vc postou, também tinha feito o backup do mmc14, nvram e um arquivo chamado config, joguei tudo de volta na pasta deles de origem pelo ES File Explorer.

Depois reiniciei e graças a Deus, tudo voltou ao normal, imei recuperado e mac da placa de rede e bt corrigidos. Até o momento, está ok.

Sei lá, mas estou pensando em voltar pra stock novamente, esperar o lineage ficar mais completo e estável, dessa vez consegui salvar meu celular, mas e na próxima? Fico com receio de não ter a mesma sorte, mas no mais, a rom stock nem chega perto da perfeição que a Lineage está, é lindo ver o zf2 fluindo normalmente, acho que até o fim do ano o LOS deve está muito melhor.

Caso volte pra stock, vou me virando com o titanium backup, comprei a licença pro dele, vai quebrar um galho.

No mais, agradeço demais pelas dicas, vc me ajudou muito até agora, muito obrigado Natanael!

Responder
  • Posts no fórum: 332

27/03/2017, 16:02:17 via App

StrikerFX

Instalei o app do google para contatos, usei a opção de importar contatos do app, não mudou, foi a mesma coisa do app nativo, não encontra nada, tanto no SIM1 ou SIM2.

Pra ferrar, o zf2 estava instável, pensei que era por causa de algo que tinha corrompido na instalação do LOS 14.1, fui fazer wipe no recovery e bam, ao voltar para o sistema, IMEI null, fiquei louco.

De início, apenas o SIM1 ficou com imei null, mas foi só desligar e religar o smart e o SIM2 foi pro buraco também.

Não satisfeito, pra zoar, o SO perde o sn, mac de rede e BT e mais algumas coisas referentes ao imei e rede, praticamente inutilizou o smart.

Sorte que eu tinha feito backup daqueles arquivos descritos no post anterior, do link que vc postou, também tinha feito o backup do mmc14, nvram e um arquivo chamado config, joguei tudo de volta na pasta deles de origem pelo ES File Explorer.

Depois reiniciei e graças a Deus, tudo voltou ao normal, imei recuperado e mac da placa de rede e bt corrigidos. Até o momento, está ok.

Sei lá, mas estou pensando em voltar pra stock novamente, esperar o lineage ficar mais completo e estável, dessa vez consegui salvar meu celular, mas e na próxima? Fico com receio de não ter a mesma sorte, mas no mais, a rom stock nem chega perto da perfeição que a Lineage está, é lindo ver o zf2 fluindo normalmente, acho que até o fim do ano o LOS deve está muito melhor.

Caso volte pra stock, vou me virando com o titanium backup, comprei a licença pro dele, vai quebrar um galho.

No mais, agradeço demais pelas dicas, vc me ajudou muito até agora, muito obrigado Natanael!

Aconselho que permaneça pelo menos até aparecer outra atualização, pode ser que esse problema seja somente da primeira instalação e não volte a acontecer.
Outro conselho, salve o backup em outro lugar (Google drive, OneDrive, mega, etc...), nunca se sabe quando irá precisar, rsrs.

Fico feliz em ter ajudado, qualquer coisa estou por aqui, rsrs

Por favor, se a resposta lhe foi útil contribua atribuindo um "Obrigado"

Dispositivo: Moto G
Modelo: XT1033
OS: Android 7.1.2 (AOSP Extended 4.2 )

Responder
  • Posts no fórum: 12

27/03/2017, 23:06:10 via Web

Natanael Caetano

StrikerFX

Instalei o app do google para contatos, usei a opção de importar contatos do app, não mudou, foi a mesma coisa do app nativo, não encontra nada, tanto no SIM1 ou SIM2.

Pra ferrar, o zf2 estava instável, pensei que era por causa de algo que tinha corrompido na instalação do LOS 14.1, fui fazer wipe no recovery e bam, ao voltar para o sistema, IMEI null, fiquei louco.

De início, apenas o SIM1 ficou com imei null, mas foi só desligar e religar o smart e o SIM2 foi pro buraco também.

Não satisfeito, pra zoar, o SO perde o sn, mac de rede e BT e mais algumas coisas referentes ao imei e rede, praticamente inutilizou o smart.

Sorte que eu tinha feito backup daqueles arquivos descritos no post anterior, do link que vc postou, também tinha feito o backup do mmc14, nvram e um arquivo chamado config, joguei tudo de volta na pasta deles de origem pelo ES File Explorer.

Depois reiniciei e graças a Deus, tudo voltou ao normal, imei recuperado e mac da placa de rede e bt corrigidos. Até o momento, está ok.

Sei lá, mas estou pensando em voltar pra stock novamente, esperar o lineage ficar mais completo e estável, dessa vez consegui salvar meu celular, mas e na próxima? Fico com receio de não ter a mesma sorte, mas no mais, a rom stock nem chega perto da perfeição que a Lineage está, é lindo ver o zf2 fluindo normalmente, acho que até o fim do ano o LOS deve está muito melhor.

Caso volte pra stock, vou me virando com o titanium backup, comprei a licença pro dele, vai quebrar um galho.

No mais, agradeço demais pelas dicas, vc me ajudou muito até agora, muito obrigado Natanael!

Aconselho que permaneça pelo menos até aparecer outra atualização, pode ser que esse problema seja somente da primeira instalação e não volte a acontecer.
Outro conselho, salve o backup em outro lugar (Google drive, OneDrive, mega, etc...), nunca se sabe quando irá precisar, rsrs.

Fico feliz em ter ajudado, qualquer coisa estou por aqui, rsrs

Eu que agradeço, sua ajuda foi importante!

Agora, uma coisa é certa: depois que vc ver a fluidez do Lineage OS com Nougat, fica muito, mas muito mais difícil se contentar com a versão Lolipop, nossa, é outro mundo totalmente diferente.

Aquela fluidez de antes passou longe no lolipop, antes quando lia algum comentário de usuários que passaram a usar CM ou LOS, ficava me questionando se tudo aquilo que eles relatavam era verdade, era mesmo tudo verdadeiro.

Acho que vou esperar até a próxima versão do Lineage, caso ela tenha melhorias, talvez eu volte novamente para ele, pois agora, sei como recuperar o smart em caso de problemas, já tenho o backup do IMEI guardado.

Outra coisa excelente foi o toolkit que usei pra desbloquear o MM para poder instalar o Lineage, pelo que o povo do xda fala, como não é um unlock oficial, vc pode relocar o bootloader novamente do zf2 pelo XFSTK e realmente é verdade, meu bootloader está 100% bloqueado, isso foi algo que adorei, pois caso o smart dê problemas futuros, ainda posso recorrer a garantia.

Deixo esse link com um guia excelente do xda: forum.xda-developers.com/zenfone2/help/thead-bricked-phone-updating-to-mm-tips-t3452785, foi com ele que consegui recuperar 100% meu zf2, talvez ajude alguém com problemas parecidos.

Washington Junior

Responder
  • Posts no fórum: 12

29/03/2017, 01:17:23 via Web

Natanael, amigo, tenho algumas novidades!

Como informei no post anterior, voltei para o android LP, pois tive o contratempo do contatos e o fato dos problemas do IMEI, mac, SN e etc.

Hoje, já fiz o que deveria ter feito a muito tempo: sincronizei os contatos com a conta do google. Não sei porque não tinha feito isso antes, tão simples e fácil.

Bastou sincronizar o smart e lá estava todos os contatos disponíveis (whew) é vivendo e aprendendo.

Fui pesquisar mais sobre os problemas que tive na instalação anterior do Lineage OS, algo que vacilei e muito foi não ter feito um backup via nandroid, algo que deveria ter feito, talvez teria me poupado de uma tremenda dor de cabeça.

Com o LP na última versão, atualizei o Zenfone 2 para o MM, instalou sem problemas.

Depois de pesquisar, percebi que alguns dos problemas na instalação anterior foram meus, por isso ocorreram os contratempos.

Já conhecendo onde errei, resolvi em definitivo reinstalar o Lineage OS, pois como lhe informei no post anterior, é difícil se contentar com alguma versão que não seja ele, o sistema é perfeito, o Zenfone 2 parece até outro smart de tão liso que ficou.

Fiz o desbloqueio do bootloader corretamente, instalando o TWRP em seguida. Reiniciei o smart pra ver se estava tudo ok, iniciou sem problemas.

Baixei a ROM do Lineage OS e o gapps, pelo TWRP, instalei o Lineage primeiro, em seguida, instalei o gapps. Reiniciei e tudo correu perfeitamente sem problema algum. Os valores do IMEI estavam todos corretos, tanto para o SIM1 e SIM2, SN com valor correto, mac e bluetooth também.

Ativei o wifi e a Play Store, atualizei o que faltava e instalei o Magisk Manager, pois pretendia instalar root no sistema. Voltei para o TWRP e finalizei instalando o magisk root, aparelho rooteado perfeitamente.

Agora sim, consegui configurar o Zenfone 2 e Lineage do jeito que eu queria, aparelho rodando liso e root funcionando perfeitamente.

Vi que muita gente estava se queixando do alto consumo da bateria nessa versão do android, mas achei que melhorou e muito, pois o zf2 dura muito mais tempo que antes pra mim.

Até o momento, estou bastante satisfeito, pois consegui o que queria: um sistema limpo, sem tralhas prejudicando a performance e totalmente atual.

No momento, só instalei 3 apps, o magisk manager que já tinha dito antes, whatsapp e titanium backup pro, estou cogitando em instalar o Pixel Launcher da google, na instalação anterior instalei e adorei, é muito mais leve e mais intuitiva que a Trebuchet.

Você tem algumas dicas ou macetes para o Lineage OS que possam melhorar ainda mais a performance dele?

— alterado em 29/03/2017, 01:18:41

Responder
  • Posts no fórum: 332

01/04/2017, 15:25:48 via App

Fico feliz que tenha dado certo.
Eu uso o pixel launcher e estou satisfeito com ele.
Para melhorar a performance eu não fiz muita coisa, só desativei a permissão de alguns apps para iniciar ao ligar ou de se manterem ativados em segundo plano.
Fui em configurações >privacidade>proteção a privacidade> menu avançado e procurando o App que desejo desativar suas permissões.

Por favor, se a resposta lhe foi útil contribua atribuindo um "Obrigado"

Dispositivo: Moto G
Modelo: XT1033
OS: Android 7.1.2 (AOSP Extended 4.2 )

StrikerFX

Responder

Artigos recomendados